- Search for defconfigs in target, not entire tree
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Mon, 25 Jun 2007 10:56:13 +0000 (10:56 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Mon, 25 Jun 2007 10:56:13 +0000 (10:56 -0000)
  This patch changes the way the top level Makefile searches for a
  <board>_defconfig file, it will only look in the target/ directory and its sub
  directories.

  The patch also enables loading a defconfig even if there already is a .config.
  (Hans-Christian Egtvedt)

Makefile

index cadbd847ff51484dba6e28bd745a66784a187509..ceaae90fb4e5e5079ecf9b842374f4ae7d461677 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -245,10 +245,6 @@ allnoconfig: $(CONFIG)/conf
 defconfig: $(CONFIG)/conf
        @$(CONFIG)/conf -d $(CONFIG_CONFIG_IN)
 
-%_defconfig: $(CONFIG)/conf
-       cp $(shell find . -name $@) .config
-       @$(CONFIG)/conf -o $(CONFIG_CONFIG_IN)
-
 # check if download URLs are outdated 
 source-check: allyesconfig
        $(MAKE) _source-check
@@ -267,6 +263,11 @@ distclean: clean
 
 endif # ifeq ($(strip $(BR2_HAVE_DOT_CONFIG)),y)
 
+%_defconfig: $(CONFIG)/conf
+       cp $(shell find ./target/ -name $@) .config
+       @$(CONFIG)/conf -o $(CONFIG_CONFIG_IN)
+
+
 .PHONY: dummy subdirs release distclean clean config oldconfig \
        menuconfig tags check test depend defconfig