package/libolm: new package
authorGilles Talis <gilles.talis@gmail.com>
Sun, 13 Oct 2019 09:30:49 +0000 (11:30 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 21 Oct 2019 21:22:52 +0000 (23:22 +0200)
libolm is an implementation of the Double Ratchet cryptographic ratchet
described by:
https://whispersystems.org/docs/specifications/doubleratchet/

Signed-off-by: Gilles Talis <gilles.talis@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/libolm/Config.in [new file with mode: 0644]
package/libolm/libolm.hash [new file with mode: 0644]
package/libolm/libolm.mk [new file with mode: 0644]

index cda6cc5da3643c4115e169b698af44678a368df2..199c59d429044b85879ce861335452951fa06c0d 100644 (file)
@@ -968,6 +968,7 @@ F:  package/fdk-aac/
 F:     package/httping/
 F:     package/iozone/
 F:     package/leptonica/
+F:     package/libolm/
 F:     package/ocrad/
 F:     package/restclient-cpp/
 F:     package/tesseract-ocr/
index e941896ea2155a2229ca1e23e564e7fbd7e3a6ad..f5af43081df44083ca4bec861f1d16dae364b7b8 100644 (file)
@@ -1245,6 +1245,7 @@ menu "Crypto"
        source "package/libmcrypt/Config.in"
        source "package/libmhash/Config.in"
        source "package/libnss/Config.in"
+       source "package/libolm/Config.in"
        source "package/libp11/Config.in"
        source "package/libscrypt/Config.in"
        source "package/libsecret/Config.in"
diff --git a/package/libolm/Config.in b/package/libolm/Config.in
new file mode 100644 (file)
index 0000000..a863216
--- /dev/null
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_LIBOLM
+       bool "libolm"
+       depends on BR2_INSTALL_LIBSTDCPP
+       depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 # C++11
+       help
+         libolm is an implementation of the Double Ratchet
+         cryptographic ratchet in C++
+
+         https://gitlab.matrix.org/matrix-org/olm
+
+comment "libolm needs a toolchain w/ C++, gcc >= 4.8"
+       depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_GCC_AT_LEAST_4_8
diff --git a/package/libolm/libolm.hash b/package/libolm/libolm.hash
new file mode 100644 (file)
index 0000000..613dda3
--- /dev/null
@@ -0,0 +1,3 @@
+# locally computed
+sha256 1ca9926ce71d778fb7352d1ee77513194db8c7f49c0d69d38ac49ec3bafcea38 olm-3.1.4.tar.gz
+sha256 0d542e0c8804e39aa7f37eb00da5a762149dc682d7829451287e11b938e94594 LICENSE
diff --git a/package/libolm/libolm.mk b/package/libolm/libolm.mk
new file mode 100644 (file)
index 0000000..78ee05b
--- /dev/null
@@ -0,0 +1,16 @@
+################################################################################
+#
+# libolm
+#
+################################################################################
+
+LIBOLM_VERSION = 3.1.4
+LIBOLM_SOURCE = olm-$(LIBOLM_VERSION).tar.gz
+LIBOLM_SITE = https://gitlab.matrix.org/matrix-org/olm/-/archive/$(LIBOLM_VERSION)
+LIBOLM_LICENSE = Apache-2.0
+LIBOLM_LICENSE_FILES = LICENSE
+LIBOLM_INSTALL_STAGING = YES
+
+LIBOLM_CONF_OPTS = -DOLM_TESTS=OFF
+
+$(eval $(cmake-package))