toolchain-external: remove Linaro 2012.08
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 27 Nov 2012 04:07:02 +0000 (04:07 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 28 Nov 2012 01:11:41 +0000 (17:11 -0800)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/toolchain-external/Config.in
toolchain/toolchain-external/ext-tool.mk

index 56630fa4fc40b8785642c278822fe6bc2023a8ff..469c2830b983cf5f3bda3243569c42b91fa37148 100644 (file)
@@ -54,23 +54,6 @@ config BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_09
 
          To use this toolchain, you must disable soft float usage.
 
-config BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_08
-       bool "Linaro 2012.08"
-       depends on BR2_arm
-       depends on BR2_cortex_a8 || BR2_cortex_a9
-       select BR2_TOOLCHAIN_EXTERNAL_GLIBC
-       select BR2_TOOLCHAIN_HAS_NATIVE_RPC
-       select BR2_INSTALL_LIBSTDCPP
-       help
-         Linaro toolchain for the ARM architecture. It uses Linaro
-         GCC 2012.08 (based on gcc 4.7), Linaro GDB 2012.06 (based on
-         GDB 7.4), eglibc 2.15. It generates code that runs on all
-         Cortex-A profile devices, but tuned for the Cortex-A9. The
-         code generated is Thumb 2, with the hard floating point
-         calling convention, and uses the VFPv3-D16 FPU instructions.
-
-         To use this toolchain, you must disable soft float usage.
-
 config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201203
        bool "Sourcery CodeBench ARM 2012.03"
        depends on BR2_arm
@@ -641,7 +624,6 @@ config BR2_TOOLCHAIN_EXTERNAL_CUSTOM_PREFIX
 
 config BR2_TOOLCHAIN_EXTERNAL_PREFIX
        string
-       default "arm-linux-gnueabihf"    if BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_08
        default "arm-linux-gnueabihf"    if BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_09
        default "arm-linux-gnueabihf"    if BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_10
        default "arm-linux-gnueabihf"    if BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_11
index d98fcc6b822b4be1da40f370fa7c808e059ab0dd..4429480af23730af3b27598c0ed9b9584c4034fc 100644 (file)
@@ -184,9 +184,6 @@ TOOLCHAIN_EXTERNAL_SOURCE=arm-2011.09-70-arm-none-linux-gnueabi-i686-pc-linux-gn
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201203),y)
 TOOLCHAIN_EXTERNAL_SITE=http://sourcery.mentor.com/public/gnu_toolchain/arm-none-linux-gnueabi/
 TOOLCHAIN_EXTERNAL_SOURCE=arm-2012.03-57-arm-none-linux-gnueabi-i686-pc-linux-gnu.tar.bz2
-else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_08),y)
-TOOLCHAIN_EXTERNAL_SITE=https://launchpad.net/linaro-toolchain-binaries/trunk/2012.08/+download/
-TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabihf-2012.08-20120827_linux.tar.bz2
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_09),y)
 TOOLCHAIN_EXTERNAL_SITE=https://launchpad.net/linaro-toolchain-binaries/trunk/2012.09/+download/
 TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabihf-2012.09-20120921_linux.tar.bz2