Add an option to allow people to relocate the toolchain
authorEric Andersen <andersen@codepoet.org>
Sat, 11 Dec 2004 10:25:40 +0000 (10:25 -0000)
committerEric Andersen <andersen@codepoet.org>
Sat, 11 Dec 2004 10:25:40 +0000 (10:25 -0000)
Config.in
package/Makefile.in

index 6d702a5a89594d8315df65e8d5418e84a266d781..8b15d11f3c2d38132beb9627891e9862607ece71 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -74,6 +74,20 @@ config BR2_WGET
        string
        default "wget --passive-ftp -nd"
 
+config BR2_STAGING_DIR
+       string "Toolchain and header file location?"
+       default "$(BUILD_DIR)/staging_dir"
+       help
+           This is the location where the toolchain will be installed.
+           Since the toolchain will not work if it is moved from this
+           location, it is important for people wishing to package up
+           a uClibc toolchain that this be set to the location in which
+           the toolchain will be used.
+
+           Most people will leave this set to the default value of
+           "$(BUILD_DIR)/staging_dir".
+
+
 config BR2_TAR_VERBOSITY
        bool
        default n
index 75173f76388e5b30c32a4843e2c4b99dabd3abf9..db523d21a3408b4e87b242eec163d32e543c8e84 100644 (file)
@@ -15,8 +15,10 @@ DL_DIR:=$(BASE_DIR)/dl
 #PATCH_DIR=$(BASE_DIR)/sources/patches
 BUILD_DIR:=$(BASE_DIR)/build_$(ARCH)$(ARCH_FPU_SUFFIX)
 TARGET_DIR:=$(BUILD_DIR)/root
-STAGING_DIR=$(BUILD_DIR)/staging_dir
 TOOL_BUILD_DIR=$(BASE_DIR)/toolchain_build_$(ARCH)$(ARCH_FPU_SUFFIX)
+# Strip off the annoying quoting
+STAGING_DIR:=$(strip $(subst ",, $(BR2_STAGING_DIR)))
+#"
 TARGET_PATH=$(STAGING_DIR)/bin:/bin:/sbin:/usr/bin:/usr/sbin
 IMAGE:=$(BASE_DIR)/root_fs_$(ARCH)$(ARCH_FPU_SUFFIX)
 REAL_GNU_TARGET_NAME=$(OPTIMIZE_FOR_CPU)-linux-uclibc