package/rpm: add optional zstd dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 30 Mar 2019 14:49:47 +0000 (15:49 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 31 Mar 2019 13:03:09 +0000 (15:03 +0200)
zstd support has been in version 4.14.0 and
https://github.com/rpm-software-management/rpm/commit/3684424fe297c996bb05bb64631336fa2903df12

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/rpm/rpm.mk

index 626e6bf94c86071ec99147a425c8ee0bc293aca8..5fd725661854396ed2e8b5b3692b702da83f9611 100644 (file)
@@ -92,6 +92,13 @@ ifeq ($(BR2_PACKAGE_BINUTILS),y)
 RPM_DEPENDENCIES += binutils
 endif
 
+ifeq ($(BR2_PACKAGE_ZSTD),y)
+RPM_DEPENDENCIES += zstd
+RPM_CONF_OPTS += --enable-zstd
+else
+RPM_CONF_OPTS += --disable-zstd
+endif
+
 # ac_cv_prog_cc_c99: RPM uses non-standard GCC extensions (ex. `asm`).
 RPM_CONF_ENV = \
        ac_cv_prog_cc_c99='-std=gnu99' \