boot/arm-trusted-firmware: don't pass TARGET_CONFIGURE_OPTS when building
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 14 Sep 2018 15:33:24 +0000 (17:33 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 11 Oct 2018 07:28:54 +0000 (09:28 +0200)
Passing CFLAGS/CPPFLAGS in the environment confuses the ATF version
provided by Marvell, and we in fact only need to pass CROSS_COMPILE,
which is already in ARM_TRUSTED_FIRMWARE_MAKE_OPTS.

We however keep TARGET_MAKE_ENV so that the PATH with $(HOST_DIR) is
kept.

This change has been tested with all current defconfigs that build
ATF:

 - arm_juno
 - bananapi_m64
 - freescale_imx8mqevk
 - friendlyarm_nanopi_a64
 - friendlyarm_nanopi_neo2
 - nitrogen8m
 - olimex_a64_olinuxino
 - orangepi_pc2
 - orangepi_prime
 - orangepi_win
 - orangepi_zero_plus2
 - pine64
 - pine64_sopine
 - solidrun_macchiatobin_mainline
 - solidrun_macchiatobin_marvell
 - zynqmp_zcu106

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
boot/arm-trusted-firmware/arm-trusted-firmware.mk

index 054a000a1dd3356370c62e45815a68fcc8e1e301..19f7c4c80a696e5a1e662e756d8e25d615eb2035 100644 (file)
@@ -96,9 +96,8 @@ endif
 
 define ARM_TRUSTED_FIRMWARE_BUILD_CMDS
        $(ARM_TRUSTED_FIRMWARE_BUILD_FIPTOOL)
-       $(TARGET_CONFIGURE_OPTS) \
-               $(MAKE) -C $(@D) $(ARM_TRUSTED_FIRMWARE_MAKE_OPTS) \
-                       $(ARM_TRUSTED_FIRMWARE_MAKE_TARGETS)
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) $(ARM_TRUSTED_FIRMWARE_MAKE_OPTS) \
+               $(ARM_TRUSTED_FIRMWARE_MAKE_TARGETS)
        $(ARM_TRUSTED_FIRMWARE_BL31_UBOOT_BUILD)
 endef