dropbear: bump to version 0.53.1
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 4 Mar 2011 14:22:26 +0000 (11:22 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 5 Mar 2011 14:37:16 +0000 (15:37 +0100)
Changelog @ http://matt.ucc.asn.au/dropbear/CHANGES

Since some build-time defaults have changed that make dropbear somewhat
bigger we introduce a new option to optimize dropbear for size.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/dropbear/Config.in
package/dropbear/dropbear.mk

index e47ba454570f20e98fe3d56fbb546d02dfbc9a35..4bc0e3e1b0f7c66a2898f0be0d2fce788eca3591 100644 (file)
@@ -13,3 +13,13 @@ config BR2_PACKAGE_DROPBEAR_DISABLE_REVERSEDNS
          Disable reverse DNS lookups on connection. This can be handy
          on systems without working DNS, as connections otherwise
          stall until DNS times out.
+
+config BR2_PACKAGE_DROPBEAR_SMALL
+       bool "optimize for size"
+       default y
+       depends on BR2_PACKAGE_DROPBEAR
+       help
+         Compile dropbear for the smallest possible binary size.
+
+         Tradeoffs are slower hashes and ciphers, and disabling of the
+         blowfish cipher.
index b07cb6333c1bd53c1f488e8d57a04ebd6c1edcf1..fab7c96789cd8d4dd55797a35e98c28c023db588 100644 (file)
@@ -4,7 +4,7 @@
 #
 #############################################################
 
-DROPBEAR_VERSION = 0.52
+DROPBEAR_VERSION = 0.53.1
 DROPBEAR_SOURCE = dropbear-$(DROPBEAR_VERSION).tar.gz
 DROPBEAR_SITE = http://matt.ucc.asn.au/dropbear/releases
 DROPBEAR_DEPENDENCIES = zlib
@@ -27,10 +27,25 @@ define DROPBEAR_DISABLE_REVERSE_DNS
        $(SED) 's,^#define DO_HOST_LOOKUP.*,/* #define DO_HOST_LOOKUP */,' $(@D)/options.h
 endef
 
+define DROPBEAR_BUILD_SMALL
+       echo "#define DROPBEAR_SMALL_CODE" >>$(@D)/options.h
+       echo "#define NO_FAST_EXPTMOD" >>$(@D)/options.h
+endef
+
+define DROPBEAR_BUILD_FEATURED
+       echo "#define DROPBEAR_BLOWFISH" >>$(@D)/options.h
+endef
+
 ifeq ($(BR2_PACKAGE_DROPBEAR_DISABLE_REVERSEDNS),y)
 DROPBEAR_POST_EXTRACT_HOOKS += DROPBEAR_DISABLE_REVERSE_DNS
 endif
 
+ifeq ($(BR2_PACKAGE_DROPBEAR_SMALL),y)
+DROPBEAR_POST_EXTRACT_HOOKS += DROPBEAR_BUILD_SMALL
+else
+DROPBEAR_POST_EXTRACT_HOOKS += DROPBEAR_BUILD_FEATURED
+endif
+
 define DROPBEAR_INSTALL_TARGET_CMDS
        $(INSTALL) -m 755 $(@D)/dropbearmulti $(TARGET_DIR)/usr/sbin/dropbear
        for f in $(DROPBEAR_TARGET_BINS); do \