package/python-aiomonitor: new package
authorJames Hilliard <james.hilliard1@gmail.com>
Sun, 3 Mar 2019 23:44:20 +0000 (07:44 +0800)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 17 Mar 2019 15:24:19 +0000 (16:24 +0100)
aiomonitor adds monitor and python REPL capabilities for
asyncio application.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/python-aiomonitor/Config.in [new file with mode: 0644]
package/python-aiomonitor/python-aiomonitor.hash [new file with mode: 0644]
package/python-aiomonitor/python-aiomonitor.mk [new file with mode: 0644]

index ae1d97152cfc147cada856d938310044d8327584..cb1c90c39dcfed2829292995468ed5c29c4af454 100644 (file)
@@ -1042,6 +1042,7 @@ F:        package/python-aiohttp-remotes/
 F:     package/python-aiohttp-security/
 F:     package/python-aiohttp-session/
 F:     package/python-aiohttp-sse/
+F:     package/python-aiomonitor/
 F:     package/python-aiojobs/
 F:     package/python-aiorwlock/
 F:     package/python-async-timeout/
index 2407c12b529413b115e8e808e23b8eef4d05a8e4..b5321aeb49c900a5f5365dfe6aa41d4877662312 100644 (file)
@@ -809,6 +809,7 @@ menu "External python modules"
        source "package/python-aiohttp-security/Config.in"
        source "package/python-aiohttp-session/Config.in"
        source "package/python-aiohttp-sse/Config.in"
+       source "package/python-aiomonitor/Config.in"
        source "package/python-aiorwlock/Config.in"
        source "package/python-aiojobs/Config.in"
        source "package/python-alsaaudio/Config.in"
diff --git a/package/python-aiomonitor/Config.in b/package/python-aiomonitor/Config.in
new file mode 100644 (file)
index 0000000..c76c952
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_PYTHON_AIOMONITOR
+       bool "python-aiomonitor"
+       depends on BR2_PACKAGE_PYTHON3
+       select BR2_PACKAGE_PYTHON_TERMINALTABLES # runtime
+       select BR2_PACKAGE_PYTHON_AIOCONSOLE # runtime
+       help
+         aiomonitor adds monitor and python REPL capabilities for
+         asyncio application.
+
+         https://github.com/aio-libs/aiomonitor
diff --git a/package/python-aiomonitor/python-aiomonitor.hash b/package/python-aiomonitor/python-aiomonitor.hash
new file mode 100644 (file)
index 0000000..ddcfd07
--- /dev/null
@@ -0,0 +1,5 @@
+# md5, sha256 from https://pypi.org/pypi/aiomonitor/json
+md5    0f58ac68497a59d104ecb6ba369df784  aiomonitor-0.4.3.tar.gz
+sha256 37cd279c26e2c80b4e6ed9d23476c84c0b75fc3794617fceb6f341437b9af5fe  aiomonitor-0.4.3.tar.gz
+# Locally computed sha256 checksums
+sha256 9b42fe3a288996988c552e387e7877be7525a1649e62086aedd6b32d3cb56365  LICENSE
diff --git a/package/python-aiomonitor/python-aiomonitor.mk b/package/python-aiomonitor/python-aiomonitor.mk
new file mode 100644 (file)
index 0000000..88f28a5
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-aiomonitor
+#
+################################################################################
+
+PYTHON_AIOMONITOR_VERSION = 0.4.3
+PYTHON_AIOMONITOR_SOURCE = aiomonitor-$(PYTHON_AIOMONITOR_VERSION).tar.gz
+PYTHON_AIOMONITOR_SITE = https://files.pythonhosted.org/packages/11/27/2d25a3318e57181e04d2694768f0e1e621b64606d8424076790caa29e401
+PYTHON_AIOMONITOR_SETUP_TYPE = setuptools
+PYTHON_AIOMONITOR_LICENSE = Apache-2.0
+PYTHON_AIOMONITOR_LICENSE_FILES = LICENSE
+
+$(eval $(python-package))