python-libconfig: fix python-3.7 support
authorBernd Kuhls <bernd.kuhls@t-online.de>
Fri, 24 Aug 2018 20:31:19 +0000 (22:31 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 24 Aug 2018 21:09:44 +0000 (23:09 +0200)
Fixes
http://autobuild.buildroot.net/results/32f/32f7e38895e7c491916bd69ed91bbe016e8b3ff6/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/python-libconfig/0001-Determine-boost_python-name-depending-on-current-Pyt.patch

index 478bac76f65517d69bc81440b9e7ee0ac9e70949..ec7aec40728e8661ab6b1581ee649cc23a459a51 100644 (file)
@@ -4,11 +4,13 @@ Date: Thu, 27 Jul 2017 09:46:07 +0200
 Subject: [PATCH] Determine boost_python name depending on current Python
  version
 
-Python2 requires boost_python27 and Python3 requires boost_python36
+Python2 requires boost_python27 and Python3 requires boost_python37
 (since boost 1.67).
 
 Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+[Bernd: adapted for python-3.7]
+Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
 ---
  setup.py | 6 +++++-
  1 file changed, 5 insertions(+), 1 deletion(-)
@@ -21,7 +23,7 @@ index fdf5c27..4b38569 100644
  from setuptools import setup, find_packages, Extension
  import sys, os
  
-+boostlib = "boost_python36"
++boostlib = "boost_python37"
 +if sys.version_info < (3, 0):
 +    boostlib = "boost_python27"
 +