package/linuxptp: rename systemd service scripts
authorHeiko Thiery <heiko.thiery@gmail.com>
Thu, 12 Mar 2020 19:04:36 +0000 (20:04 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 14 Mar 2020 14:33:03 +0000 (15:33 +0100)
Use the same name as for the SysVinit scripts. This name is also used in
debian.

linuxptp-system-clock.service -> phc2sys.service
linuxptp.service -> ptp4l.service

Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>
Tested-by: Carlos Santos <unixmania@gmail.com>
Tested-by: Carlos Santos <unixmania@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/linuxptp/linuxptp-system-clock.service [deleted file]
package/linuxptp/linuxptp.mk
package/linuxptp/linuxptp.service [deleted file]
package/linuxptp/phc2sys.service [new file with mode: 0644]
package/linuxptp/ptp4l.service [new file with mode: 0644]

diff --git a/package/linuxptp/linuxptp-system-clock.service b/package/linuxptp/linuxptp-system-clock.service
deleted file mode 100644 (file)
index 57beec4..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=Precision Time Protocol system clock synchronization
-After=linuxptp.service
-
-[Service]
-ExecStart=/usr/sbin/phc2sys -s /dev/ptp0 -c CLOCK_REALTIME -w -S 1.0
-Restart=always
-
-[Install]
-WantedBy=multi-user.target
index ba57396f86d2c2508a003b78e83d6e60d0fd1d21..921c55ad59a824b183687c9475df6eb0ab0c25db 100644 (file)
@@ -40,10 +40,10 @@ define LINUXPTP_INSTALL_INIT_SYSV
 endef
 
 define LINUXPTP_INSTALL_INIT_SYSTEMD
-       $(INSTALL) -D -m 644 $(LINUXPTP_PKGDIR)/linuxptp.service \
-               $(TARGET_DIR)/usr/lib/systemd/system/linuxptp.service
-       $(INSTALL) -D -m 644 $(LINUXPTP_PKGDIR)/linuxptp-system-clock.service \
-               $(TARGET_DIR)/usr/lib/systemd/system/linuxptp-system-clock.service
+       $(INSTALL) -D -m 644 $(LINUXPTP_PKGDIR)/ptp4l.service \
+               $(TARGET_DIR)/usr/lib/systemd/system/ptp4l.service
+       $(INSTALL) -D -m 644 $(LINUXPTP_PKGDIR)/phc2sys.service \
+               $(TARGET_DIR)/usr/lib/systemd/system/phc2sys.service
 endef
 
 $(eval $(generic-package))
diff --git a/package/linuxptp/linuxptp.service b/package/linuxptp/linuxptp.service
deleted file mode 100644 (file)
index 14e9814..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-[Unit]
-Description=Precision Time Protocol daemon
-After=syslog.target network.target
-Before=time-sync.target
-Wants=time-sync.target
-Wants=linuxptp-system-clock.service
-
-[Service]
-ExecStart=/usr/sbin/ptp4l -f /etc/linuxptp.cfg
-Restart=always
-
-[Install]
-WantedBy=multi-user.target
diff --git a/package/linuxptp/phc2sys.service b/package/linuxptp/phc2sys.service
new file mode 100644 (file)
index 0000000..63b0ca2
--- /dev/null
@@ -0,0 +1,10 @@
+[Unit]
+Description=Precision Time Protocol system clock synchronization
+After=ptp4l.service
+
+[Service]
+ExecStart=/usr/sbin/phc2sys -s /dev/ptp0 -c CLOCK_REALTIME -w -S 1.0
+Restart=always
+
+[Install]
+WantedBy=multi-user.target
diff --git a/package/linuxptp/ptp4l.service b/package/linuxptp/ptp4l.service
new file mode 100644 (file)
index 0000000..07f0b68
--- /dev/null
@@ -0,0 +1,13 @@
+[Unit]
+Description=Precision Time Protocol daemon
+After=syslog.target network.target
+Before=time-sync.target
+Wants=time-sync.target
+Wants=phc2sys.service
+
+[Service]
+ExecStart=/usr/sbin/ptp4l -f /etc/linuxptp.cfg
+Restart=always
+
+[Install]
+WantedBy=multi-user.target