package/p11-kit: security bump to version 0.23.22
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 8 Jan 2021 18:11:57 +0000 (19:11 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 9 Jan 2021 15:09:14 +0000 (16:09 +0100)
- Fix memory-safety issues that affect the RPC protocol (CVE-2020-29361,
  CVE-2020-29362 and CVE-2020-29363)
- Update indentation in hash file (two spaces)

https://github.com/p11-glue/p11-kit/blob/0.23.22/NEWS

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/p11-kit/0001-p11-kit-lists-c-Add-stdint-h-to-fix-compilation.patch [new file with mode: 0644]
package/p11-kit/p11-kit.hash
package/p11-kit/p11-kit.mk

diff --git a/package/p11-kit/0001-p11-kit-lists-c-Add-stdint-h-to-fix-compilation.patch b/package/p11-kit/0001-p11-kit-lists-c-Add-stdint-h-to-fix-compilation.patch
new file mode 100644 (file)
index 0000000..d482866
--- /dev/null
@@ -0,0 +1,28 @@
+From 507c394cfcf4edffc5e4450c5d737e545c26b857 Mon Sep 17 00:00:00 2001
+From: Daniel Engberg <daniel.engberg.lists@pyret.net>
+Date: Sat, 12 Dec 2020 18:56:38 +0100
+Subject: [PATCH] p11-kit/lists.c: Add stdint.h to fix compilation
+
+Add stdint.h otherwise compilation fails on FreeBSD 13-CURRENT with "use of undeclared identifier 'SIZE_MAX'"
+
+Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
+
+[Retrieved from:
+https://github.com/p11-glue/p11-kit/commit/507c394cfcf4edffc5e4450c5d737e545c26b857]
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+---
+ p11-kit/lists.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/p11-kit/lists.c b/p11-kit/lists.c
+index 365a6d89..1d9062be 100644
+--- a/p11-kit/lists.c
++++ b/p11-kit/lists.c
+@@ -39,6 +39,7 @@
+ #include <assert.h>
+ #include <ctype.h>
++#include <stdint.h>
+ #include <string.h>
+ #include <stdio.h>
+ #include <stdlib.h>
index 45f0f1d64e73319b1a584426f6ee6e2791316ee8..3481a40b001388e808a30fbff28e748a524ed36b 100644 (file)
@@ -1,4 +1,4 @@
 # Locally calculated after checking pgp signature
-sha256 4b34e92ae36fa493e0d94366c767f06d5f9951e3d8581d10fd935d738db1574d  p11-kit-0.23.16.1.tar.gz
+sha256  8a8f40153dd5a3f8e7c03e641f8db400133fb2a6a9ab2aee1b6d0cb0495ec6b6  p11-kit-0.23.22.tar.xz
 # Locally computed
-sha256 2e1ba993904df807a10c3eda1e5c272338edc35674b679773a8b3ad460731054  COPYING
+sha256  2e1ba993904df807a10c3eda1e5c272338edc35674b679773a8b3ad460731054  COPYING
index 1ffc7e21c80f0a8360f6c6bd001caace39dc334a..81972f811bd570135a4c8cab785c5c6d3ba9b29b 100644 (file)
@@ -4,7 +4,8 @@
 #
 ################################################################################
 
-P11_KIT_VERSION = 0.23.16.1
+P11_KIT_VERSION = 0.23.22
+P11_KIT_SOURCE = p11-kit-$(P11_KIT_VERSION).tar.xz
 P11_KIT_SITE = https://github.com/p11-glue/p11-kit/releases/download/$(P11_KIT_VERSION)
 P11_KIT_INSTALL_STAGING = YES
 P11_KIT_CONF_OPTS = --disable-static