Don't use a string to do the job of a bool
authorEric Andersen <andersen@codepoet.org>
Sat, 9 Oct 2004 21:12:25 +0000 (21:12 -0000)
committerEric Andersen <andersen@codepoet.org>
Sat, 9 Oct 2004 21:12:25 +0000 (21:12 -0000)
Config.in
Makefile

index 0b6edd59afc1eede4ab57b02e07d2753b5a22353..306239396e980069b087384248c717125e999414 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -63,8 +63,8 @@ config BR2_WGET
        default "wget --passive-ftp"
 
 config BR2_TAR_VERBOSITY
-       string
-       default "no"
+       bool
+       default n
 
 source "toolchain/Config.in"
 
index e810ecf1312a5a77d249b2d86c9eaf7516dfa514..1c6bc767ce7195ea6249c75c82d6c5ca8a64d8fa 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -35,7 +35,7 @@ ifeq ($(filter $(noconfig_targets),$(MAKECMDGOALS)),)
 -include $(TOPDIR).config
 endif
 
-ifeq ($(strip $(BR2_TAR_VERBOSITY)),"yes")
+ifeq ($(BR2_TAR_VERBOSITY),y)
 TAR_VERBOSITY=v
 else
 TAR_VERBOSITY=