linphone: arc: Undefine __arc__ when building for ARC processors
authorAnton Kolesov <anton.kolesov@synopsys.com>
Fri, 4 Apr 2014 16:04:38 +0000 (20:04 +0400)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 12 Apr 2014 15:41:15 +0000 (17:41 +0200)
This patch is similar to 821a6d63. Libexosip2 defines symbol __arc__, which
gets in contradiction with same symbol defined by the GCC for the Synopsys
DesignWare ARC cores. Previous patch undefined __arc__ for libosip2 and
libexosip2, however linphone includes headers from libexosip2, which causes
build failure unless same patch is applied to it.

This patch fixes
http://autobuild.buildroot.net/results/0d2e19d40d6d0df4048e6ebae5f77022f89ca7cb/

Signed-off-by: Anton Kolesov <Anton.Kolesov@synopsys.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/linphone/linphone.mk

index 91830aebc96742f3fa7eacd79eb630322a8da54d..5e960a0cf9455e7a3f1434dc741c52f91d0390c0 100644 (file)
@@ -17,6 +17,11 @@ LINPHONE_DEPENDENCIES = host-pkgconf ortp mediastreamer libeXosip2 speex
 LINPHONE_LICENSE = GPLv2+
 LINPHONE_LICENSE_FILES = COPYING
 
+ifeq ($(BR2_arc),y)
+# toolchain __arc__ define conflicts with libosip2 source
+LINPHONE_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -U__arc__"
+endif
+
 ifeq ($(BR2_PACKAGE_LIBGTK2)$(BR2_PACKAGE_XORG7),yy)
 LINPHONE_CONF_OPT += --enable-gtk_ui
 LINPHONE_DEPENDENCIES += libgtk2