package/gst1-plugins-bad: add webrtc option
authorPeter Seiderer <ps.report@gmx.net>
Sat, 16 Mar 2019 22:14:40 +0000 (23:14 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 18 Mar 2019 21:19:08 +0000 (22:19 +0100)
- remove old webrtc Config.in.legacy entry introduced by [1] (misnamed
  webrtc option was introduced with 2017.02, renamed to webrtcdsp for
  2017.08 and although backported to 2017.02.4)

[1] https://git.buildroot.net/buildroot/commit/?id=4c06d2490a07f0b88f42c56c7409899fd2f5608a

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Config.in.legacy
package/gstreamer1/gst1-plugins-bad/Config.in
package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk

index 2030b51e1d530b7d9588f12c02732c9d3a7d6fd2..0a0bce41f9c59af500a9ba969d6e1137dc594e4b 100644 (file)
@@ -1685,16 +1685,6 @@ config BR2_PACKAGE_GST1_PLUGINS_UGLY_PLUGIN_MAD
        bool "mad (*.mp3 audio) removed"
        select BR2_LEGACY
 
-config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_WEBRTC
-       bool "gst1-plugins-bad webrtc renamed to webrtcdsp"
-       select BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_WEBRTCDSP
-       select BR2_LEGACY
-       help
-         The WebRTC plugin in GStreamer 1.x has always been named
-         webrtcdsp, but was wrongly introduced in Buildroot under the
-         name webrtc. Therefore, we have renamed the option to match
-         the actual name of the GStreamer plugin.
-
 config BR2_STRIP_none
        bool "Strip command 'none' has been removed"
        select BR2_LEGACY
index 869f0a9d45ce751ad16f08089a3bde5a132c6905..6830902f3a6978ff547619d46a37b4285b86c50f 100644 (file)
@@ -558,6 +558,17 @@ config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_WEBP
        help
          Webp image format plugin
 
+config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_WEBRTC
+       bool "webrtc"
+       depends on !BR2_STATIC_LIBS # libnice -> gnutls
+       select BR2_PACKAGE_GST1_PLUGINS_BASE # libgstsdp
+       select BR2_PACKAGE_LIBNICE
+       help
+         WebRTC plugins (webrtcbin - a bin for webrtc connections)
+
+comment "webrtc needs a toolchain w/ dynamic library"
+       depends on BR2_STATIC_LIBS
+
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_WEBRTCDSP
        bool "webrtcdsp"
        # All depends from webrtc-audio-processing
index f5b081f9724daaadb99214442825f9b694121589..e4e7661ac4237666052839d11b6bc356940573ad 100644 (file)
@@ -703,6 +703,13 @@ else
 GST1_PLUGINS_BAD_CONF_OPTS += --disable-webp
 endif
 
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_WEBRTC),y)
+GST1_PLUGINS_BAD_CONF_OPTS += --enable-webrtc
+GST1_PLUGINS_BAD_DEPENDENCIES += gst1-plugins-base libnice
+else
+GST1_PLUGINS_BAD_CONF_OPTS += --disable-webrtc
+endif
+
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_WEBRTCDSP),y)
 GST1_PLUGINS_BAD_CONF_OPTS += --enable-webrtcdsp
 GST1_PLUGINS_BAD_DEPENDENCIES += webrtc-audio-processing