package/upmpdcli: fix static build issue
authorJörg Krause <joerg.krause@embedded.rocks>
Thu, 24 Jan 2019 10:07:17 +0000 (11:07 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 27 Jan 2019 20:46:03 +0000 (21:46 +0100)
The spotify plugin requires shared library support and needs <dlfcn.h>.
Explicitly disable the spotify plugin when building upmpdcli in a static
context.

Fixes:
http://autobuild.buildroot.net/results/cb942d3c5f68959d6cbc85535ccff4a275369f91/

Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/upmpdcli/upmpdcli.mk

index d88caac78bf8442189bfa59f17e58570f9f18558..22a5bf24298924219128aea1b5e805025ac56fb8 100644 (file)
@@ -10,6 +10,11 @@ UPMPDCLI_LICENSE = LGPL-2.1+
 UPMPDCLI_LICENSE_FILES = COPYING
 UPMPDCLI_DEPENDENCIES = host-pkgconf libmpdclient libupnpp libmicrohttpd jsoncpp
 
+# Disable spotify plugin which requires dlfcn.h
+ifeq ($(BR2_STATIC_LIBS),y)
+UPMPDCLI_CONF_OPTS = --disable-spotify
+endif
+
 # Upmpdcli only runs if user upmpdcli exists
 define UPMPDCLI_USERS
        upmpdcli -1 upmpdcli -1 * - - audio Upmpdcli MPD UPnP Renderer Front-End