infra: introduce github helper function
authorMischa Jonker <Mischa.Jonker@synopsys.com>
Thu, 5 Dec 2013 17:20:44 +0000 (18:20 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 6 Dec 2013 21:34:51 +0000 (22:34 +0100)
In order to make it easier to cope with changes in github download-URL's,
this patch introduces the github helper function. It generates the site
URL of a github repository. It's usage is $(call github,user,pkg,version).

[Thomas: extracted from Mischa original commit, macro moved to
pkg-download.mk]

Signed-off-by: Mischa Jonker <mjonker@synopsys.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pkg-download.mk

index 8e4a1ec33ba634502797660817cee1a31279438b..758b211097e888f5d818a035cc551ab9e1b4cb20 100644 (file)
@@ -55,6 +55,9 @@ notdomain=$(patsubst $(call domain,$(1),$(2))$(call domainseparator,$(2))%,%,$(c
 # default domainseparator is /, specify alternative value as first argument
 domainseparator=$(if $(1),$(1),/)
 
+# github(user,package,version): returns site of github repository
+github = https://github.com/$(1)/$(2)/tarball/$(3)
+
 ################################################################################
 # The DOWNLOAD_* helpers are in charge of getting a working copy
 # of the source repository for their corresponding SCM,