package/wine: add gettext dependency for host-wine only with NLS enabled
authorVadim Kochan <vadim4j@gmail.com>
Sat, 5 Jan 2019 20:00:44 +0000 (22:00 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 6 Feb 2019 13:11:13 +0000 (14:11 +0100)
Checked that host-wine compiles ok without host-gettext, so no needs
to specify this dependency.

libgettextpo is required by tools/wrc
(https://linux.die.net/man/1/wrc) which allows to convert windows
resources also to *.po format, which is not needed if NLS is disabled.

Signed-off-by: Vadim Kochan <vadim4j@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/wine/wine.mk

index 78c8e6ab630c3cbb1840bb1f78afb780b77833e7..7e44e3c81d16e66a62bab5c0d93711f9ff7fa9a8 100644 (file)
@@ -307,8 +307,12 @@ WINE_CONF_OPTS += --without-zlib
 endif
 
 # host-gettext is essential for .po file support in host-wine wrc
+ifeq ($(BR2_SYSTEM_ENABLE_NLS),y)
 HOST_WINE_DEPENDENCIES += host-gettext
 HOST_WINE_CONF_OPTS += --with-gettext --with-gettextpo
+else
+HOST_WINE_CONF_OPTS += --without-gettext --without-gettextpo
+endif
 
 # Wine needs to enable 64-bit build tools on 64-bit host
 ifeq ($(HOSTARCH),x86_64)