uclibc: fix testsuite
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 10 Feb 2016 14:17:58 +0000 (11:17 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 12 Feb 2016 13:50:56 +0000 (14:50 +0100)
Unless the tests are built with TEST_INSTALLED_UCLIBC their rpath will
point to the build directory rather than runtime directory, resulting in
non-executable tests for the target.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/uclibc/uclibc.mk

index 773b22a15958155e1fd9011e7da6a3d10ac3cc7c..200de043e4a9ee198ec54b0d88011da746918052 100644 (file)
@@ -386,6 +386,7 @@ ifeq ($(BR2_UCLIBC_INSTALL_TEST_SUITE),y)
 define UCLIBC_BUILD_TEST_SUITE
        $(MAKE1) -C $(@D) \
                $(UCLIBC_MAKE_FLAGS) \
+               TEST_INSTALLED_UCLIBC=1 \
                UCLIBC_ONLY=1 \
                test_compile
 endef