projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
f8ce3d3
)
musl: honor static vs. shared library options
author
Charles Duffy
<charles@dyfis.net>
Wed, 14 Oct 2015 04:29:37 +0000
(23:29 -0500)
committer
Thomas Petazzoni
<thomas.petazzoni@free-electrons.com>
Thu, 15 Oct 2015 07:38:08 +0000
(09:38 +0200)
[Thomas: use SHARED_STATIC_LIBS_OPTS to simplify the logic.]
Signed-off-by: Charles Duffy <chaduffy@cisco.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/musl/musl.mk
patch
|
blob
|
history
diff --git
a/package/musl/musl.mk
b/package/musl/musl.mk
index 22589f544e0403f096857f57f39065b849cd5411..f0c45f538b03756934314c70fdeb06ffa55b9124 100644
(file)
--- a/
package/musl/musl.mk
+++ b/
package/musl/musl.mk
@@
-28,7
+28,8
@@
define MUSL_CONFIGURE_CMDS
--host=$(GNU_TARGET_NAME) \
--prefix=/usr \
--libdir=/lib \
- --disable-gcc-wrapper)
+ --disable-gcc-wrapper \
+ $(SHARED_STATIC_LIBS_OPTS))
endef
define MUSL_BUILD_CMDS