package/asterisk: add optional alsa-lib dependency
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 9 Sep 2017 21:39:12 +0000 (23:39 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sat, 23 Sep 2017 17:20:18 +0000 (19:20 +0200)
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/asterisk/asterisk.mk

index 8d21601e3e6579a653019ba0ddf5fc6c9cfcb93b..7ef449ffeafd2c3dd49d11950fcad154959bcfbd 100644 (file)
@@ -48,7 +48,6 @@ ASTERISK_CONF_OPTS = \
        --disable-internal-poll \
        --disable-asteriskssl \
        --disable-rpath \
-       --without-asound \
        --without-bfd \
        --without-bluetooth \
        --without-cap \
@@ -144,6 +143,13 @@ else
 ASTERISK_CONF_OPTS += --without-gsm
 endif
 
+ifeq ($(BR2_PACKAGE_ALSA_LIB),y)
+ASTERISK_DEPENDENCIES += alsa-lib
+ASTERISK_CONF_OPTS += --with-asound
+else
+ASTERISK_CONF_OPTS += --without-asound
+endif
+
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 ASTERISK_DEPENDENCIES += openssl
 ASTERISK_CONF_OPTS += --with-ssl