package/nut: install to staging
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 22 Aug 2020 08:56:42 +0000 (10:56 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 24 Aug 2020 20:54:54 +0000 (22:54 +0200)
Needed for collectd plugin.

Added --with-dev to enable install of pkgconfig files:
https://github.com/networkupstools/nut/blob/master/lib/Makefile.am#L3

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/nut/nut.mk

index 4ea9947128da6f385c603f2927f1ad7433f1a5b3..593d19926ab5986279c4d59560493cad77207c7e 100644 (file)
@@ -9,6 +9,7 @@ NUT_VERSION = $(NUT_VERSION_MAJOR).4
 NUT_SITE = http://www.networkupstools.org/source/$(NUT_VERSION_MAJOR)
 NUT_LICENSE = GPL-2.0+, GPL-3.0+ (python scripts), GPL/Artistic (perl client)
 NUT_LICENSE_FILES = COPYING LICENSE-GPL2 LICENSE-GPL3
+NUT_INSTALL_STAGING = YES
 NUT_DEPENDENCIES = host-pkgconf
 
 # Our patch changes m4 macros, so we need to autoreconf
@@ -21,6 +22,7 @@ NUT_MAKE = $(MAKE1)
 # since the default location (/var/state/ups) maybe readonly.
 NUT_CONF_OPTS = \
        --with-altpidpath=/var/run/upsd \
+       --with-dev \
        --without-hal
 
 # For uClibc-based toolchains, nut forgets to link with -lm