haserl: Add lua option
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 29 Apr 2010 21:04:20 +0000 (18:04 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 1 May 2010 20:36:02 +0000 (22:36 +0200)
Closes #719

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/haserl/Config.in
package/haserl/haserl.mk

diff --git a/CHANGES b/CHANGES
index e574c907db6c93950dedabb718c87bc429798bc6..deabb09dcf15b65c9ac0a2e0495ff94c74f246f8 100644 (file)
--- a/CHANGES
+++ b/CHANGES
        New packages: librsync, libatomic_ops, libusb-compat, lmbench,
        netperf, squid
 
-       Updated/fixed packages: alsa-utils, busybox, dnsmasq, dosfstools,
-       e2fsprogs, eeprog, fbv, freetype, hostapd, iperf, iptables, iw, less,
-       libaio,libdrm, libgcrypt, libglib2, libpng, libxml2, lua, matchbox,
-       mdadm, memstat, mesa3d, mtd-utils, nano, openssl, pciutils,
-       php, pixman, portage, pppd, pthread-stubs, python, qt, radvd,
-       samba, setserial, squashfs, tslib, usb_modeswith, wget,
-       xdata_xcursor-themes, xdriver_xf86-video-intel,
-       xkeyboard-config, xlib_libX11, xlib_libXaw, xlib_libXfont,
-       xlib_libXfontcache, xlib_libXxf86misc, xlib_libXtst,
-       xlib_libpciaccess, xproto_dri2proto, xproto_eviext,
-       xproto_fontcacheproto, xproto_xf86miscproto,
-       xserver_xorg-server
+       Updated/fixed packages: alsa-utils, busybox, dnsmasq,
+       dosfstools, e2fsprogs, eeprog, fbv, freetype, haserl, hostapd,
+       iperf, iptables, iw, less, libaio,libdrm, libgcrypt, libglib2,
+       libpng, libxml2, lua, matchbox, mdadm, memstat, mesa3d,
+       mtd-utils, nano, openssl, pciutils, php, pixman, portage,
+       pppd, pthread-stubs, python, qt, radvd, samba, setserial,
+       squashfs, tslib, usb_modeswith, wget, xdata_xcursor-themes,
+       xdriver_xf86-video-intel, xkeyboard-config, xlib_libX11,
+       xlib_libXaw, xlib_libXfont, xlib_libXfontcache,
+       xlib_libXxf86misc, xlib_libXtst, xlib_libpciaccess,
+       xproto_dri2proto, xproto_eviext, xproto_fontcacheproto,
+       xproto_xf86miscproto, xserver_xorg-server
 
        Removed packages: xapp_xtrap, xlib_libXTrap, xlib_libXevie,
        xlib_libXxf86misc, xxproto_evieext, proto_trapproto,
@@ -33,6 +33,7 @@
 
        #513: Add new squid package
        #661: lmbench: new package
+       #719: Add lua option to haserl
        #800: [PATCH] iperf update to 2.0.4
        #803: [PATCH] lua - add shared library patch and config option for...
        #805: [PATCH] mdadm - version update
index 21ab63c9cf995b4a16954f340825fed811585db0..a8d2ee5a89d6972cd2b068ce06d09e7d15f6abd7 100644 (file)
@@ -7,6 +7,14 @@ config BR2_PACKAGE_HASERL
 
          http://haserl.sourceforge.net/
 
+config BR2_PACKAGE_HASERL_WITH_LUA
+       bool "lua support"
+       depends on BR2_PACKAGE_HASERL
+       depends on BR2_PACKAGE_HASERL_VERSION_0_9_X
+       select BR2_PACKAGE_LUA
+       help
+         Enable LUA support for haserl
+
 choice
        prompt "Haserl version"
        default BR2_PACKAGE_HASERL_VERSION_0_9_X
index 41b89aeb7a6e48fcfe56b767e7e0c2468cbe5cbd..257a257ae14944ebb08415ce67e0b93aa956bdd1 100644 (file)
@@ -5,10 +5,8 @@
 #############################################################
 
 HASERL_VERSION:=$(call qstrip,$(BR2_PACKAGE_HASERL_VERSION))
-HASERL_SOURCE:=haserl-$(HASERL_VERSION).tar.gz
 HASERL_SITE:=http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/haserl/
-HASERL_AUTORECONF:=no
-HASERL_INSTALL_STAGING:=NO
+HASERL_AUTORECONF:=NO
 HASERL_INSTALL_TARGET:=YES
 ifeq ($(BR2_ENABLE_DEBUG),)
 HASERL_INSTALL_TARGET_OPT:=DESTDIR=$(TARGET_DIR) STRIPPROG='$(STRIPCMD)' install-strip
@@ -18,6 +16,11 @@ endif
 HASERL_CONF_ENV = ac_cv_path_install=./install-sh
 # the above doesn't interact nicely with a shared cache, so disable for now
 HASERL_USE_CONFIG_CACHE = NO
+ifeq ($(BR2_PACKAGE_HASERL_WITH_LUA),y)
+       HASERL_CONF_OPT += --with-lua=$(STAGING_DIR) \
+               --with-lua-headers=$(STAGING_DIR)
+       HASERL_DEPENDENCIES += lua
+endif
 
 $(eval $(call AUTOTARGETS,package,haserl))