sdl: fix build without directfb after autotools conversion
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 25 Jun 2010 10:25:57 +0000 (12:25 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 25 Jun 2010 10:25:57 +0000 (12:25 +0200)
Make sure --enable-video-directfb=no gets passed to configure
if directfb isn't enabled, so sdl doesn't try to link with the
host version instead (if available).

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/sdl/sdl.mk

index 44981ea4d03a0eb04ff400fecd9b65fd15c59d51..87c753370995a1bb6b3eb2bf7d710e986aa27767 100644 (file)
@@ -20,7 +20,7 @@ ifeq ($(BR2_PACKAGE_SDL_DIRECTFB),y)
 SDL_DEPENDENCIES += directfb
 SDL_CONF_OPT+=--enable-video-directfb=yes
 else
-SDL_DIRECTFB=--enable-video-directfb=no
+SDL_CONF_OPT=--enable-video-directfb=no
 endif
 
 ifeq ($(BR2_PACKAGE_SDL_QTOPIA),y)