qt: update x86x86fix for 32bit pc hosts
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 21 May 2010 06:53:34 +0000 (08:53 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 21 May 2010 06:53:34 +0000 (08:53 +0200)
The recent change to use config.guess to figure out GNU_HOST_NAME
broken the x86x86fix detection for 32bit hosts, as config.guess
returns something like i686-pc-linux-gnu rather than something with
*-unknown-linux-* like we used to use.

Fix it by simply looking for "linux" instead.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/qt/qt.mk

diff --git a/CHANGES b/CHANGES
index 8c6d645a2a4ec30fcc4ca3d25f00ddb6117fcbd8..7a3fe09f4e5384923e52dd71748af2b14a48103e 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -2,7 +2,7 @@
 
        Fixes all over the tree.
 
-       Updated/fixed packages: aumix, avahi, busybox, mtd-utils, ntp
+       Updated/fixed packages: aumix, avahi, busybox, mtd-utils, ntp, qt
 
        Issues resolved (http://bugs.uclibc.org):
 
index 4f42e59e86d4f38223d7ef10559a9f0c06b641f6..aaf965e3c84b230cf7f167d6e2f5799a9e13ea5e 100644 (file)
@@ -372,7 +372,7 @@ BR2_PACKAGE_QT_EMB_PLATFORM:=$(call qstrip,$(BR2_PACKAGE_QT_EMB_PLATFORM))
 # x86x86fix
 # Workaround Qt Embedded bug when crosscompiling for x86 under x86 with linux
 # host. It's unclear if this would happen on other hosts.
-ifneq ($(findstring unknown-linux,$(GNU_HOST_NAME)),)
+ifneq ($(findstring linux,$(GNU_HOST_NAME)),)
 ifneq ($(findstring x86,$(BR2_PACKAGE_QT_EMB_PLATFORM)),)
 QT_CONFIGURE+= -platform linux-g++
 endif