package/ltp-testsuite: remove ldd command test with static only build
authorRomain Naour <romain.naour@gmail.com>
Tue, 9 May 2017 20:59:27 +0000 (22:59 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 10 May 2017 21:35:54 +0000 (23:35 +0200)
ldd command build system try to build a shared library unconditionally:

arc-linux-gcc -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -matomic -Os -static \
-I[...]/sysroot/usr/include/tirpc   -g -O2 -fno-strict-aliasing -pipe \
-Wall -W -Wold-style-definition -shared -o lddfile1.obj.so lddfile1.o

Fixes:
http://autobuild.buildroot.net/results/2ec/2eccf9f517ab15d8d459b06195423fdfe3fba9fa

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/ltp-testsuite/ltp-testsuite.mk

index 7f26bd2a59c1ce81ff80ef96ecb83ea9923e4869..a4546dff8208d1450bc1777962a291d681048238 100644 (file)
@@ -68,4 +68,12 @@ endef
 LTP_TESTSUITE_POST_PATCH_HOOKS += LTP_TESTSUITE_REMOVE_UNSUPPORTED
 endif
 
+# ldd command build system tries to build a shared library unconditionally.
+ifeq ($(BR2_STATIC_LIBS),y)
+define LTP_TESTSUITE_REMOVE_LDD
+       rm -rf $(@D)/testcases/commands/ldd
+endef
+LTP_TESTSUITE_POST_PATCH_HOOKS += LTP_TESTSUITE_REMOVE_LDD
+endif
+
 $(eval $(autotools-package))