perl-dbd-mysql: new package
authorChristopher McCrory <chrismcc@gmail.com>
Mon, 20 Aug 2018 11:55:03 +0000 (04:55 -0700)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 11 Sep 2018 13:39:10 +0000 (15:39 +0200)
Signed-off-by: Christopher McCrory <chrismcc@gmail.com>
Acked-by: Francois Perrad <francois.perrad@gadz.org>
[Thomas: properly propagate BR2_PACKAGE_MYSQL dependencies]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/perl-dbd-mysql/Config.in [new file with mode: 0644]
package/perl-dbd-mysql/perl-dbd-mysql.hash [new file with mode: 0644]
package/perl-dbd-mysql/perl-dbd-mysql.mk [new file with mode: 0644]

index b05564dd44e0e178af6a1b80b90f6704a0a186f7..8c43ce1b174d46273297844a7a301e105bd7e93b 100644 (file)
@@ -492,6 +492,7 @@ F:  package/perl-class-std-fast/
 F:     package/perl-data-optlist/
 F:     package/perl-data-uuid/
 F:     package/perl-date-manip/
+F:     package/perl-dbd-mysql/
 F:     package/perl-dbi/
 F:     package/perl-device-serialport/
 F:     package/perl-file-slurp/
index fb4d3288461d8351146ffca2e7363b437f338e4c..046ddd5310adbd296884380eb326cdaffe9d456f 100644 (file)
@@ -678,6 +678,7 @@ menu "Perl libraries/modules"
        source "package/perl-data-uuid/Config.in"
        source "package/perl-date-manip/Config.in"
        source "package/perl-datetime-tiny/Config.in"
+       source "package/perl-dbd-mysql/Config.in"
        source "package/perl-dbi/Config.in"
        source "package/perl-device-serialport/Config.in"
        source "package/perl-digest-hmac/Config.in"
diff --git a/package/perl-dbd-mysql/Config.in b/package/perl-dbd-mysql/Config.in
new file mode 100644 (file)
index 0000000..f6cc3f9
--- /dev/null
@@ -0,0 +1,17 @@
+config BR2_PACKAGE_PERL_DBD_MYSQL
+       bool "perl-dbd-mysql"
+       depends on !BR2_STATIC_LIBS
+       depends on BR2_INSTALL_LIBSTDCPP # mysql
+       depends on BR2_USE_MMU # mysql
+       depends on BR2_TOOLCHAIN_HAS_THREADS # mysql
+       select BR2_PACKAGE_PERL_DBI
+       select BR2_PACKAGE_MYSQL
+       help
+         A MySQL driver for the Perl5 Database Interface (DBI)
+
+         http://dbi.perl.org/
+
+comment "perl-dbd-mysql needs a toolchain w/ dynamic library, C++, threads"
+       depends on BR2_USE_MMU
+       depends on BR2_STATIC_LIBS || !BR2_INSTALL_LIBSTDCPP || \
+               !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/perl-dbd-mysql/perl-dbd-mysql.hash b/package/perl-dbd-mysql/perl-dbd-mysql.hash
new file mode 100644 (file)
index 0000000..51de476
--- /dev/null
@@ -0,0 +1,6 @@
+# retrieved by scancpan from http://cpan.metacpan.org/
+md5    bdf4f4d899b8af29ebd8ebfb7438d05f DBD-mysql-4.046.tar.gz
+sha256 6165652ec959d05b97f5413fa3dff014b78a44cf6de21ae87283b28378daf1f7 DBD-mysql-4.046.tar.gz
+
+# computed by scancpan
+sha256 7a9ba29702b957805cfa8aa63bca43175625824263232dbade0010d385ab888c LICENSE
diff --git a/package/perl-dbd-mysql/perl-dbd-mysql.mk b/package/perl-dbd-mysql/perl-dbd-mysql.mk
new file mode 100644 (file)
index 0000000..560b97b
--- /dev/null
@@ -0,0 +1,15 @@
+################################################################################
+#
+# perl-dbd-mysql
+#
+################################################################################
+
+PERL_DBD_MYSQL_VERSION = 4.046
+PERL_DBD_MYSQL_SOURCE = DBD-mysql-$(PERL_DBD_MYSQL_VERSION).tar.gz
+PERL_DBD_MYSQL_SITE = $(BR2_CPAN_MIRROR)/authors/id/C/CA/CAPTTOFU
+PERL_DBD_MYSQL_DEPENDENCIES = host-perl-dbi perl-dbi mysql
+PERL_DBD_MYSQL_CONF_OPTS = --mysql_config=$(STAGING_DIR)/usr/bin/mysql_config
+PERL_DBD_MYSQL_LICENSE = Artistic or GPL-1.0+
+PERL_DBD_MYSQL_LICENSE_FILES = LICENSE
+
+$(eval $(perl-package))