boost: add option to disable container library
authorWill Wagner <will_wagner@carallon.com>
Mon, 20 Apr 2015 10:15:02 +0000 (11:15 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 20 Apr 2015 20:35:58 +0000 (22:35 +0200)
Signed-off-by: Will Wagner <will_wagner@carallon.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/boost/Config.in
package/boost/boost.mk

index 5444c422f5c0ffe93fede7d9755ce779236e761c..add7069e335dc84d0d56aaf2992807efa4baf841 100644 (file)
@@ -55,6 +55,9 @@ config BR2_PACKAGE_BOOST_ATOMIC
 config BR2_PACKAGE_BOOST_CHRONO
        bool "boost-chrono"
 
+config BR2_PACKAGE_BOOST_CONTAINER
+       bool "boost-container"
+
 config BR2_PACKAGE_BOOST_CONTEXT
        bool "boost-context"
        depends on (BR2_arm || BR2_armeb || BR2_i386 || BR2_mips || BR2_mipsel \
index 56a6c347ca21a38c0d6198cd209c231760f0fdaa..7060591411d093e31fea8066756887a58dd9d354 100644 (file)
@@ -28,6 +28,7 @@ BOOST_WITHOUT_FLAGS = coroutine
 
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_ATOMIC),,atomic)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_CHRONO),,chrono)
+BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_CONTAINER),,container)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_CONTEXT),,context)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_DATE_TIME),,date_time)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_EXCEPTION),,exception)