imx-alsa-plugins: new package
authorJörg Krause <joerg.krause@embedded.rocks>
Thu, 1 Feb 2018 13:26:29 +0000 (14:26 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 30 Apr 2018 15:49:35 +0000 (17:49 +0200)
Freescale specific alsa-lib plugins for the i.MX processor family.

For now, the only provided plugin is:
  * Rate Converter Plugin Using Freescale ASRC Resampler

The ASRC hardware resampler can be found on i.MX53 and most i.MX 6
processors.

Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
[Thomas:
 - Remove the mention "This package is provided by Freescale as-is and
   doesn't have an upstream." from the Config.in help text, since
   according to Gary Bisson, there is a Git repository for such
   projects, and therefore some form of upstream.
 - Add missing entry to DEVELOPERS file.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/freescale-imx/Config.in
package/freescale-imx/imx-alsa-plugins/Config.in [new file with mode: 0644]
package/freescale-imx/imx-alsa-plugins/imx-alsa-plugins.hash [new file with mode: 0644]
package/freescale-imx/imx-alsa-plugins/imx-alsa-plugins.mk [new file with mode: 0644]

index d8f429f989f792bf926592ff47fdd70ea66afe93..bbb586e7db75de32990c33a0f3fdc9ac6eb26d1c 100644 (file)
@@ -1036,6 +1036,7 @@ F:        board/lemaker/bananapro/
 F:     configs/bananapro_defconfig
 F:     package/augeas/
 F:     package/bctoolbox/
+F:     package/freescale-imx/imx-alsa-plugins/
 F:     package/libshout/
 F:     package/libupnpp/
 F:     package/luv/
index d7f260dd7a9ef96044961ea447b004daa936937c..97aeb15764e4331cc72f23b7471bbb9a45699ec1 100644 (file)
@@ -71,6 +71,7 @@ config BR2_PACKAGE_FREESCALE_IMX_HAS_VIV_GPU
                BR2_PACKAGE_FREESCALE_IMX_PLATFORM_IMX6S || \
                BR2_PACKAGE_FREESCALE_IMX_PLATFORM_IMX7
 
+source "package/freescale-imx/imx-alsa-plugins/Config.in"
 source "package/freescale-imx/imx-codec/Config.in"
 source "package/freescale-imx/imx-kobs/Config.in"
 source "package/freescale-imx/imx-lib/Config.in"
diff --git a/package/freescale-imx/imx-alsa-plugins/Config.in b/package/freescale-imx/imx-alsa-plugins/Config.in
new file mode 100644 (file)
index 0000000..ec9b5b1
--- /dev/null
@@ -0,0 +1,22 @@
+config BR2_PACKAGE_IMX_ALSA_PLUGINS
+       bool "imx-alsa-plugins"
+       depends on BR2_arm # Only relevant for i.MX
+       depends on BR2_LINUX_KERNEL
+       depends on BR2_TOOLCHAIN_HAS_THREADS # alsa-lib
+       select BR2_PACKAGE_ALSA_LIB
+       help
+         ALSA plugins specific for the Freescale i.MX platform. It
+         requires a kernel that includes the i.MX specific headers
+         to be built.
+
+         The following plugins are provided so far:
+           * Rate Converter Plugin Using Freescale ASRC Hardware
+             Resampler (i.MX53 and most i.MX6)
+
+comment "imx-alsa-libs needs an imx-specific Linux kernel to be built"
+       depends on BR2_arm
+       depends on !BR2_LINUX_KERNEL
+
+comment "imx-alsa-libs needs a toolchain w/ threads"
+       depends on BR2_arm
+       depends on BR2_LINUX_KERNEL && !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/freescale-imx/imx-alsa-plugins/imx-alsa-plugins.hash b/package/freescale-imx/imx-alsa-plugins/imx-alsa-plugins.hash
new file mode 100644 (file)
index 0000000..b0f4708
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally calculated:
+sha256  e76a71e9166fbedeaa535fd7ebc07edc30a1e87f529ab2aa733e3603d3183ed0  imx-alsa-plugins-rel_imx_4.9.x_1.0.0_ga.tar.gz
+sha256  32b1062f7da84967e7019d01ab805935caa7ab7321a7ced0e30ebe75e5df1670  COPYING.GPL
diff --git a/package/freescale-imx/imx-alsa-plugins/imx-alsa-plugins.mk b/package/freescale-imx/imx-alsa-plugins/imx-alsa-plugins.mk
new file mode 100644 (file)
index 0000000..9c81ff0
--- /dev/null
@@ -0,0 +1,21 @@
+################################################################################
+#
+# imx-alsa-plugins
+#
+################################################################################
+
+IMX_ALSA_PLUGINS_VERSION = rel_imx_4.9.x_1.0.0_ga
+IMX_ALSA_PLUGINS_SITE = https://source.codeaurora.org/external/imx/imx-alsa-plugins
+IMX_ALSA_PLUGINS_SITE_METHOD = git
+IMX_ALSA_PLUGINS_LICENSE = GPL-2.0+
+IMX_ALSA_PLUGINS_LICENSE_FILES = COPYING.GPL
+IMX_ALSA_PLUGINS_DEPENDENCIES = host-pkgconf alsa-lib
+
+# git, no configure
+IMX_ALSA_PLUGINS_AUTORECONF = YES
+
+# needs access to imx-specific kernel headers
+IMX_ALSA_PLUGINS_DEPENDENCIES += linux
+IMX_ALSA_PLUGINS_CONF_ENV += CPPFLAGS="$(TARGET_CPPFLAGS) -idirafter $(LINUX_DIR)/include/uapi"
+
+$(eval $(autotools-package))