u-boot: simplify custom patch handling
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 15 Mar 2010 22:25:53 +0000 (23:25 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 10 Jun 2010 19:05:13 +0000 (21:05 +0200)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
boot/u-boot/Config.in
boot/u-boot/u-boot.mk

index 4c76d57b97da2c4f37318be6918f53959b901495..78a195d25d1ab74c5d9fcff3d2ce360f03396d02 100644 (file)
@@ -33,10 +33,13 @@ config BR2_UBOOT_VERSION
        default "2009.11"       if BR2_TARGET_UBOOT_2009_11
        default "2009.08"       if BR2_TARGET_UBOOT_2009_08
 
-config BR2_TARGET_UBOOT_CUSTOM_PATCH
-       string "custom patch"
+config BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR
+       string "custom patch dir"
        help
-         If your board requires a custom patch, add the path to the file here.
+         If your board requires custom patches, add the path to the
+         directory containing the patches here. The patches must be
+         named u-boot-<version>-<something>.patch.
+
          Most users may leave this empty
 
 choice
index 4edef12f4e2d2918a9b8d2c3117ec5db7354e554..efde3ea991771065664709249d8564044e929155 100644 (file)
@@ -9,7 +9,6 @@ U_BOOT_SOURCE:=u-boot-$(U_BOOT_VERSION).tar.bz2
 
 U_BOOT_SITE:=ftp://ftp.denx.de/pub/u-boot
 U_BOOT_DIR:=$(BUILD_DIR)/u-boot-$(U_BOOT_VERSION)
-U_BOOT_PATCH_DIR:=$(BUILD_DIR)/u-boot-$(U_BOOT_VERSION)-patches
 U_BOOT_CAT:=$(BZCAT)
 U_BOOT_BIN:=u-boot.bin
 U_BOOT_TARGET_BIN:=u-boot-$(U_BOOT_VERSION)-$(DATE).bin
@@ -69,13 +68,8 @@ $(U_BOOT_DIR)/.patched: $(U_BOOT_DIR)/.unpacked
        toolchain/patch-kernel.sh $(U_BOOT_DIR) boot/u-boot \
                u-boot-$(U_BOOT_VERSION)-\*.patch \
                u-boot-$(U_BOOT_VERSION)-\*.patch.$(ARCH)
-ifneq ($(strip $(U_BOOT_ARCH_PATCH_DIR)),)
-       toolchain/patch-kernel.sh $(U_BOOT_DIR) $(U_BOOT_ARCH_PATCH_DIR) \*.patch
-endif
-ifneq ($(strip $(BR2_TARGET_UBOOT_CUSTOM_PATCH)),"")
-       @mkdir -p $(U_BOOT_PATCH_DIR)
-       cp -dpr $(BR2_TARGET_UBOOT_CUSTOM_PATCH) $(U_BOOT_PATCH_DIR)
-       toolchain/patch-kernel.sh $(U_BOOT_DIR) $(U_BOOT_PATCH_DIR) \*.patch
+ifneq ($(qstrip $(BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR)),)
+       toolchain/patch-kernel.sh $(U_BOOT_DIR) $(U_BOOT_CUSTOM_PATCH_DIR) u-boot-$(U_BOOT_VERSION)-\*.patch
 endif
        touch $@