- add possibility to select different flavours of strip (or none at all for debugging...
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Tue, 31 Jul 2007 18:06:50 +0000 (18:06 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Tue, 31 Jul 2007 18:06:50 +0000 (18:06 -0000)
Config.in
package/Makefile.in

index cdc66663f27666b814942cdc82cfbfe2865cecf5..ca21595482b6f5797ace76e882fbc393e33a36b4 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -652,11 +652,36 @@ config BR2_DEPRECATED
          This option hides outdated/obsolete versions of packages.
 
 config BR2_USE_WCHAR
-       bool "Show packages that are require WCHAR support"
+       bool "Show packages that require WCHAR support"
        default y
        help
          This option hides packages which cannot be built without WCHAR.
 
+choice
+       prompt "strip"
+       default BR2_STRIP_strip
+       help
+         Select whether to strip binaries and libraries for the target
+         or not.
+         strip   is the normal strip command
+         sstrip  is a strip that discards more than the normal strip
+         none    do not strip (only for debugging!)
+
+config BR2_STRIP_strip
+       bool "strip"
+       help
+         strip   is the normal strip command
+config BR2_STRIP_sstrip
+       bool "sstrip"
+       select BR2_PACKAGE_SSTRIP_HOST
+       help
+         sstrip  is a strip that discards more than the normal strip
+config BR2_STRIP_none
+       bool "none"
+       help
+         none    do not strip (only for debugging!)
+endchoice
+
 config BR2_PREFER_STATIC_LIB
        bool "prefer static libraries"
        default n
index 17302527da9ea4c946408cc13605a564d065f730..071635b58cc60d0dd6bd94d8caf5ce0673efbd35 100644 (file)
@@ -131,9 +131,16 @@ endif
 TARGET_CC=$(TARGET_CROSS)gcc
 TARGET_CXX=$(TARGET_CROSS)g++
 TARGET_RANLIB=$(TARGET_CROSS)ranlib
-STRIP=$(TARGET_CROSS)strip --remove-section=.comment --remove-section=.note
 INSTALL=/usr/bin/install
-
+ifeq ($(BR2_STRIP_strip),y)
+STRIP=$(TARGET_CROSS)strip --remove-section=.comment --remove-section=.note
+endif
+ifeq ($(BR2_STRIP_sstrip),y)
+STRIP=$(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-sstrip
+endif
+ifeq ($(BR2_STRIP_none),y)
+STRIP=true -Not_stripping
+endif
 
 HOST_ARCH:=$(shell $(HOSTCC) -dumpmachine | sed -e s'/-.*//' \
        -e 's/sparc.*/sparc/' \