projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
efbd36a
)
barebox: fix ARCH value for arm64
author
Raphaël Poggi
<poggi.raph@gmail.com>
Fri, 12 Aug 2016 14:31:52 +0000
(16:31 +0200)
committer
Peter Korsgaard
<peter@korsgaard.com>
Tue, 16 Aug 2016 06:05:05 +0000
(08:05 +0200)
barebox 2016.08 added arm64 support using ARCH=arm.
[Peter: extend commit message to clarify]
Signed-off-by: Raphael Poggi <poggi.raph@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
boot/barebox/barebox.mk
patch
|
blob
|
history
diff --git
a/boot/barebox/barebox.mk
b/boot/barebox/barebox.mk
index 832297eef6f73256daee54b52bfe827104558364..7a110d214575c2b0d4ae2fc5ab019e22e89477c2 100644
(file)
--- a/
boot/barebox/barebox.mk
+++ b/
boot/barebox/barebox.mk
@@
-61,6
+61,8
@@
else ifeq ($$(KERNEL_ARCH),x86_64)
$(1)_ARCH = x86
else ifeq ($$(KERNEL_ARCH),powerpc)
$(1)_ARCH = ppc
+else ifeq ($$(KERNEL_ARCH),arm64)
+$(1)_ARCH = arm
else
$(1)_ARCH = $$(KERNEL_ARCH)
endif