Remove libgcc_eh hack. Things now build as they are supposed to.
authorManuel Novoa III <mjn3@codepoet.org>
Tue, 25 Nov 2003 14:45:40 +0000 (14:45 -0000)
committerManuel Novoa III <mjn3@codepoet.org>
Tue, 25 Nov 2003 14:45:40 +0000 (14:45 -0000)
make/gcc-3.3.mk

index 0a12d043c8764547c27982b93641573e7e1ccd86..1976f629399659b6f5851c7612ce7ff10f79b4cd 100644 (file)
@@ -445,8 +445,6 @@ $(TARGET_DIR)/usr/bin/gcc: $(GCC_BUILD_DIR3)/.compiled
        -mv $(TARGET_DIR)/lib/*.a $(TARGET_DIR)/usr/lib/
        -mv $(TARGET_DIR)/lib/*.la $(TARGET_DIR)/usr/lib/
        rm -f $(TARGET_DIR)/lib/libstdc++.so*
-       # A nasty hack to work around g++ adding -lgcc_eh to the link
-       -(cd $(TARGET_DIR)/usr/lib/gcc-lib/$(ARCH)-linux/$(GCC_VERSION)/ ; ln -s libgcc.a libgcc_eh.a)
        # Make sure gcc does not think we are cross compiling
        $(SED) "s/^1/0/;" $(TARGET_DIR)/usr/lib/gcc-lib/$(ARCH)-linux/$(GCC_VERSION)/specs
        -(cd $(TARGET_DIR)/bin; find -type f | xargs $(STRIP) > /dev/null 2>&1)