add selectable commit id to mtd-utils
authorJohn Voltz <john.voltz@gmail.com>
Thu, 24 Apr 2008 13:26:25 +0000 (13:26 -0000)
committerJohn Voltz <john.voltz@gmail.com>
Thu, 24 Apr 2008 13:26:25 +0000 (13:26 -0000)
package/mtd/Config.in
package/mtd/mtd-utils.git/mtd-utils-all-argp.patch [new file with mode: 0644]
package/mtd/mtd-utils.git/mtd.mk

index 7e43ac3c5f4bbe37e117ca9c9c5024a0b1940bcc..6013a8ff4f2d2e704523250da907e7d172d72b5c 100644 (file)
@@ -37,6 +37,18 @@ config BR2_PACKAGE_MTD_UTILS_GIT
 
 endchoice
 
+config BR2_PACKAGE_MTD_UTILS_GIT_COMMIT_ID
+       string  "Commit ID to use"
+       default "e6088d987c545d60a86e1f44836ab8ba072fffd9"
+       depends on BR2_PACKAGE_MTD_UTILS_GIT
+       help
+         If you wish to use the mtd-utils.git tree as of a specific
+         commit, you can enter the commit ID here (for example,
+         e6088d987c545d60a86e1f44836ab8ba072fffd9). 
+
+         Alternatively you can specify HEAD. Note that the current
+         HEAD will be downloaded but won't be tracked when it changes.
+
 comment "MTD tools selection"
        depends BR2_PACKAGE_MTD
 
diff --git a/package/mtd/mtd-utils.git/mtd-utils-all-argp.patch b/package/mtd/mtd-utils.git/mtd-utils-all-argp.patch
new file mode 100644 (file)
index 0000000..04ea332
--- /dev/null
@@ -0,0 +1,10 @@
+--- mtd-utils-e6088d987c545d60a86e1f44836ab8ba072fffd9/ubi-utils/new-utils/src/ubicrc32.c.orig 2008-03-26 16:08:13.000000000 +1100
++++ mtd-utils-e6088d987c545d60a86e1f44836ab8ba072fffd9/ubi-utils/new-utils/src/ubicrc32.c      2008-03-26 16:08:20.000000000 +1100
+@@ -26,7 +26,6 @@
+ #include <stdint.h>
+ #include <stdlib.h>
+ #include <getopt.h>
+-#include <argp.h>
+ #include <unistd.h>
+ #include <mtd/ubi-header.h>
index df32f53341fad41443f775a29b3d10b07f3c5c4e..79512abd56d084ab4a557a03113c73e4ff08f649 100644 (file)
@@ -3,7 +3,8 @@
 # mtd provides jffs2 utilities
 #
 #############################################################
-MTD_VERSION:=fcb52ccc99679460640386c297023f852b108f68
+MTD_VERSION:=$(strip $(subst ",, $(BR2_PACKAGE_MTD_UTILS_GIT_COMMIT_ID)))
+#"))
 MTD_SOURCE:=mtd-utils-$(MTD_VERSION).tar.gz
 MTD_URL:=http://git.infradead.org/mtd-utils.git?a=snapshot;h=$(MTD_VERSION);sf=tgz
 MTD_HOST_DIR:= $(TOOL_BUILD_DIR)/mtd-utils-$(MTD_VERSION)
@@ -21,7 +22,7 @@ MKFS_JFFS2 := $(MTD_HOST_DIR)/mkfs.jffs2
 SUMTOOL := $(MTD_HOST_DIR)/sumtool
 
 $(DL_DIR)/$(MTD_SOURCE):
-       $(WGET) -O $(DL_DIR)/$(MTD_SOURCE) "$(MTD_URL)"
+       $(WGET) -O $(DL_DIR)/$(MTD_SOURCE) $(MTD_URL)
 
 $(MTD_HOST_DIR)/.unpacked: $(DL_DIR)/$(MTD_SOURCE)
        $(MTD_CAT) $(DL_DIR)/$(MTD_SOURCE) | tar -C $(TOOL_BUILD_DIR) $(TAR_OPTIONS) -
@@ -63,7 +64,6 @@ mtd-host-dirclean:
 #############################################################
 $(MTD_DIR)/.unpacked: $(DL_DIR)/$(MTD_SOURCE)
        $(MTD_CAT) $(DL_DIR)/$(MTD_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
-       rm -rf $(MTD_DIR)
        mv $(BUILD_DIR)/$(MTD_NAME) $(MTD_DIR)
        toolchain/patch-kernel.sh $(MTD_DIR) package/mtd/mtd-utils.git mtd-utils-all\*.patch
        toolchain/patch-kernel.sh $(MTD_DIR) package/mtd/mtd-utils.git mtd-utils-target\*.patch
@@ -108,7 +108,7 @@ MTD_BUILD_TARGETS := $(addprefix $(MTD_DIR)/, $(MTD_TARGETS_y)) $(addprefix $(MT
 
 $(MTD_BUILD_TARGETS): $(MTD_DIR)/.unpacked
        mkdir -p $(TARGET_DIR)/usr/sbin
-       $(MAKE1) OPTFLAGS="-DNEED_BCOPY -Dbcmp=memcmp -I$(STAGING_DIR)/usr/include $(TARGET_CFLAGS)" \
+       $(MAKE) OPTFLAGS="-DNEED_BCOPY -Dbcmp=memcmp -I$(STAGING_DIR)/usr/include $(TARGET_CFLAGS)" \
               BUILDDIR=$(MTD_DIR) \
               CROSS=$(TARGET_CROSS) CC=$(TARGET_CC) WITHOUT_XATTR=1 -C $(MTD_DIR)