lrzsz: add lrz/lsz symlinks
authorMike Frysinger <vapier@gentoo.org>
Sat, 20 Nov 2010 05:27:34 +0000 (00:27 -0500)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 24 Nov 2010 21:30:57 +0000 (22:30 +0100)
Many systems support automatic zmodem transfers without needing to first
manually run the zmodem utils.  But the expectation is to run `lrz` and
not `rz`.  So install symlinks for lrz->rz and lsz->sz to support this.

This also includes a small fix to also remove sz when cleaning.

[Peter: use addprefix rather than patsubst]
Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/lrzsz/lrzsz.mk

diff --git a/CHANGES b/CHANGES
index 8a560fe0acf7019e0df1b1bac18281c72f354c04..05c9554138a704a26542d4ef72f1af553588ac0e 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -3,7 +3,7 @@
        Fixes all over the tree.
 
        Updated/fixed packages: bash, bind, busybox, libglib2,
-       libcurl, libmad, midori, module-init-tools, mtd-utils,
+       libcurl, libmad, lrzsz, midori, module-init-tools, mtd-utils,
        openssh, openssl, pciutils, qt, sqlite, sysstat, webkit, zlib
 
        Issues resolved (http://bugs.uclibc.org):
index 0b7f4e636e7f1e3027fe260a497050cd1243e541..2fce39c7842e2441b757982ed26fc6b4f6216188 100644 (file)
@@ -39,10 +39,12 @@ endef
 define LRZSZ_INSTALL_TARGET_CMDS
        cp $(@D)/src/lrz $(TARGET_DIR)/usr/bin/rz
        cp $(@D)/src/lsz $(TARGET_DIR)/usr/bin/sz
+       ln -s rz $(TARGET_DIR)/usr/bin/lrz
+       ln -s sz $(TARGET_DIR)/usr/bin/lsz
 endef
 
 define LRZSZ_CLEAN_CMDS
-       rm -f $(TARGET_DIR)/usr/bin/rz
+       rm -f $(addprefix $(TARGET_DIR)/usr/bin/,rz sz lrz lsz)
        -$(MAKE) -C $(@D) clean
 endef