lttng-libust: add python as optional dependency
authorRomain Naour <romain.naour@openwide.fr>
Sat, 19 Apr 2014 09:47:33 +0000 (11:47 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 19 Apr 2014 16:53:56 +0000 (18:53 +0200)
Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/lttng-libust/lttng-libust.mk

index b6d1911fb308695cb04e34c1ad0f14ed6f13e0e9..34945374bf54cf10c6569deb45eaf6cecef72db2 100644 (file)
@@ -15,4 +15,12 @@ LTTNG_LIBUST_DEPENDENCIES    = liburcu util-linux
 
 LTTNG_LIBUST_AUTORECONF = YES
 
+ifeq ($(BR2_PACKAGE_PYTHON),y)
+LTTNG_LIBUST_DEPENDENCIES += python
+else ifeq ($(BR2_PACKAGE_PYTHON3),y)
+LTTNG_LIBUST_DEPENDENCIES += python3
+else
+LTTNG_LIBUST_CONF_ENV=am_cv_pathless_PYTHON="none"
+endif
+
 $(eval $(autotools-package))