inotify-tools: Add new package
authorMike Williams <mike@mikebwilliams.com>
Mon, 25 Jul 2011 21:46:55 +0000 (17:46 -0400)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 26 Jul 2011 13:02:09 +0000 (15:02 +0200)
Adds support for inotify-tools, which are useful for scripting the
Linux inotify API.

[Peter: needs largefile support]
Signed-off-by: Mike Williams <mike@mikebwilliams.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/inotify-tools/Config.in [new file with mode: 0644]
package/inotify-tools/inotify-tools.mk [new file with mode: 0644]

index 812a730d163913c0d7edf4e5b7eda58bcfbababe..61f82560e1e8df1bc35765cb647298d42ec22e85 100644 (file)
@@ -491,6 +491,7 @@ source "package/dash/Config.in"
 endif
 source "package/dialog/Config.in"
 source "package/file/Config.in"
+source "package/inotify-tools/Config.in"
 source "package/lockfile-progs/Config.in"
 source "package/logrotate/Config.in"
 source "package/screen/Config.in"
diff --git a/package/inotify-tools/Config.in b/package/inotify-tools/Config.in
new file mode 100644 (file)
index 0000000..ed94b3f
--- /dev/null
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_INOTIFY_TOOLS
+       bool "inotify-tools"
+       depends on BR2_LARGEFILE
+       help
+         inotify-tools is a C library and a set of command-line
+         programs for Linux providing a simple interface to inotify.
+         These programs can be used to monitor and act upon
+         filesystem events. Provides the 'inotifywait' and 'inotifywatch'
+         binaries.
+
+         https://github.com/rvoicilas/inotify-tools
+
+comment "inotify-tools requires a toolchain with LARGEFILE support"
+       depends on !BR2_LARGEFILE
diff --git a/package/inotify-tools/inotify-tools.mk b/package/inotify-tools/inotify-tools.mk
new file mode 100644 (file)
index 0000000..d6378bb
--- /dev/null
@@ -0,0 +1,8 @@
+#############################################################
+#
+# inotify-utils
+#
+#############################################################
+INOTIFY_TOOLS_VERSION = 3.14
+INOTIFY_TOOLS_SITE = http://github.com/downloads/rvoicilas/inotify-tools/
+$(eval $(call AUTOTARGETS,package,inotify-tools))