libvncserver: disable libva support
authorFloris Bos <bos@je-eigen-domein.nl>
Sat, 27 Dec 2014 17:01:31 +0000 (18:01 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 27 Dec 2014 17:46:51 +0000 (18:46 +0100)
The libvncclient library (part of libvncserver) has optional support
for HW accelerated H264 video playback using libva

However there are currently two problems with it:

1) it only supports libva compiled with X11 support enabled, but it
   does not verify that is the case, resulting in compile errors.

2) it only supports the libva 1.0.x API, and not newer
   libva versions, like 1.4.x we include with buildroot.

   https://github.com/LibVNC/libvncserver/issues/11

Disabling libva support for now.

Signed-off-by: Floris Bos <bos@je-eigen-domein.nl>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libvncserver/libvncserver.mk

index ced6689038a310885bb2697e4915a7af8267b659..a8389b4203d9440558dabd18eff59c3f3dc9acde 100644 (file)
@@ -17,6 +17,10 @@ LIBVNCSERVER_DEPENDENCIES = host-pkgconf
 # tarball, so we need to generate them.
 LIBVNCSERVER_AUTORECONF = YES
 
+# libvncserver does not get along with newer libva versions
+# https://github.com/LibVNC/libvncserver/issues/11
+LIBVNCSERVER_CONF_OPTS += --without-libva
+
 # only used for examples
 LIBVNCSERVER_CONF_OPTS += --with-sdl-config=/bin/false