package/python-hiredis: new package
authorGrzegorz Blach <grzegorz@blach.pl>
Sun, 17 Mar 2019 19:05:39 +0000 (20:05 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 4 Aug 2019 10:15:46 +0000 (12:15 +0200)
Python extension that wraps protocol parsing code in hiredis.
It primarily speeds up parsing of multi bulk replies.

https://github.com/redis/hiredis-py

Signed-off-by: Grzegorz Blach <grzegorz@blach.pl>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
DEVELOPERS
package/Config.in
package/python-hiredis/Config.in [new file with mode: 0644]
package/python-hiredis/python-hiredis.hash [new file with mode: 0644]
package/python-hiredis/python-hiredis.mk [new file with mode: 0644]

index 8a83f748d13b8897af5820deaa8d10413f1bbee0..6f554896f0db646600a0a0922a1e4de49d7be96d 100644 (file)
@@ -971,6 +971,7 @@ F:  package/pigpio/
 F:     package/python-aioblescan/
 F:     package/python-falcon/
 F:     package/python-ifaddr/
+F:     package/python-hiredis/
 F:     package/python-mimeparse/
 F:     package/python-pigpio/
 F:     package/python-pyjwt/
index f84effff01a8b31f8aa2ba92b42fd5db7705eaf9..82107aec4584e5da7de4b60912988cb0c14af2e7 100644 (file)
@@ -902,6 +902,7 @@ menu "External python modules"
        source "package/python-gobject/Config.in"
        source "package/python-gunicorn/Config.in"
        source "package/python-h2/Config.in"
+       source "package/python-hiredis/Config.in"
        source "package/python-hpack/Config.in"
        source "package/python-html5lib/Config.in"
        source "package/python-httplib2/Config.in"
diff --git a/package/python-hiredis/Config.in b/package/python-hiredis/Config.in
new file mode 100644 (file)
index 0000000..a401de0
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_PYTHON_HIREDIS
+       bool "python-hiredis"
+       help
+         Python wrapper for hiredis.
+
+         https://github.com/redis/hiredis-py
diff --git a/package/python-hiredis/python-hiredis.hash b/package/python-hiredis/python-hiredis.hash
new file mode 100644 (file)
index 0000000..2ab6766
--- /dev/null
@@ -0,0 +1,6 @@
+# md5, sha256 from https://pypi.org/pypi/hiredis/json
+md5    46bc0d51bda994611bae77c044b1398b  hiredis-1.0.0.tar.gz
+sha256 e97c953f08729900a5e740f1760305434d62db9f281ac351108d6c4b5bf51795  hiredis-1.0.0.tar.gz
+# Locally computed sha256 checksums
+sha256 70edfa6d3e11f9d7497c2c2f298d06f33b11d10f37f76605102c5ab3b1f28262  COPYING
+sha256 dca05ce8fc87a8261783b4aed0deef8becc9350b6aa770bc714d0c1833b896eb  vendor/hiredis/COPYING
diff --git a/package/python-hiredis/python-hiredis.mk b/package/python-hiredis/python-hiredis.mk
new file mode 100644 (file)
index 0000000..780ec0c
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-hiredis
+#
+################################################################################
+
+PYTHON_HIREDIS_VERSION = 1.0.0
+PYTHON_HIREDIS_SOURCE = hiredis-$(PYTHON_HIREDIS_VERSION).tar.gz
+PYTHON_HIREDIS_SITE = https://files.pythonhosted.org/packages/9e/e0/c160dbdff032ffe68e4b3c576cba3db22d8ceffc9513ae63368296d1bcc8
+PYTHON_HIREDIS_SETUP_TYPE = setuptools
+PYTHON_HIREDIS_LICENSE = BSD-3-Clause
+PYTHON_HIREDIS_LICENSE_FILES = COPYING vendor/hiredis/COPYING
+
+$(eval $(python-package))