added dev files in target option
authorJohn Voltz <john.voltz@gmail.com>
Mon, 10 Mar 2008 15:22:43 +0000 (15:22 -0000)
committerJohn Voltz <john.voltz@gmail.com>
Mon, 10 Mar 2008 15:22:43 +0000 (15:22 -0000)
Config.in
Makefile
package/Makefile.autotools.in

index 5bc4e3615754199a1629bb566863f2c900caf1b9..17b1d503e87ff3e5e303b260260ad882fe8e12ec 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -239,6 +239,13 @@ config BR2_HAVE_INFOPAGES
          If you say n here, your target will not contain any
          infopage.
 
+config BR2_TARGET_DEV_FILES
+       bool "Development files in target filesystem"
+       default n
+       help
+         Install headers and static libraries in the
+         target filesystem
+
 source package/gnuconfig/Config.in
 
 endmenu
index 9a08d718f851f88b1cec27ce7d0986dfe88ba136..5e57f16254f046982902c0097551107f418ba10d 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -245,7 +245,7 @@ include package/*/*.mk
 # target stuff is last so it can override anything else
 include target/Makefile.in
 
-TARGETS+=erase-fakeroots
+TARGETS+=erase-fakeroots target-devfiles
 
 TARGETS_CLEAN:=$(patsubst %,%-clean,$(TARGETS))
 TARGETS_SOURCE:=$(patsubst %,%-source,$(TARGETS) $(BASE_TARGETS))
@@ -317,6 +317,21 @@ $(TARGET_DIR): $(PROJECT_BUILD_DIR)/.root
 erase-fakeroots:
        rm -f $(PROJECT_BUILD_DIR)/.fakeroot*
 
+target-devfiles:
+ifeq ($(strip $(BR2_TARGET_DEV_FILES)),y)
+       cp -a $(STAGING_DIR)/usr/include $(TARGET_DIR)/usr
+       cp $(STAGING_DIR)/usr/lib/*.a $(TARGET_DIR)/usr/lib
+       cp $(STAGING_DIR)/lib/*.a $(TARGET_DIR)/lib
+       cp $(STAGING_DIR)/usr/lib/*.la $(TARGET_DIR)/usr/lib
+       cp $(STAGING_DIR)/lib/*.la $(TARGET_DIR)/lib
+else
+       rm -rf $(TARGET_DIR)/usr/include
+       find $(TARGET_DIR)/usr/lib -name '*.a' -delete
+       find $(TARGET_DIR)/lib -name '*.a' -delete
+       find $(TARGET_DIR)/usr/lib -name '*.la' -delete
+       find $(TARGET_DIR)/lib -name '*.la' -delete
+endif
+
 source: $(TARGETS_SOURCE) $(HOST_SOURCE)
 
 _source-check:
index 358e71613b4610723ecf6ec450ade7d876e7e24d..7b08be1a5b95bb4cfecc3c40094e2d95af420d54 100644 (file)
@@ -230,10 +230,6 @@ $(BUILD_DIR)/%/.stamp_target_installed:
        $(if $(BR2_HAVE_INCLUDES),,for d in include; do \
                rm -rf $(TARGET_DIR)/$$d $(TARGET_DIR)/usr/$$d; \
        done)
-       find $(TARGET_DIR) -name '*.la' -delete
-       find $(TARGET_DIR)/lib -name '*.a' -delete
-       find $(TARGET_DIR)/usr/lib -name '*.a' -delete
-
        touch $@
 
 $(BUILD_DIR)/%/.stamp_cleaned: