luajit: bug fix - prevent target CFLAGS from being used in host tool compile.
authorDanomi Manchego <danomimanchego123@gmail.com>
Wed, 15 Aug 2012 01:25:30 +0000 (21:25 -0400)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 26 Aug 2012 09:18:34 +0000 (11:18 +0200)
The luajit amalgamation compile starts with building a host tool, and then
uses it to build itself.  However, when CFLAGS is specified, as opposed to
TARGET_CFLAGS, then it is used for both HOST and TARGET builds.  So if you
add something target specific into 'Target Optimizations' (for example,
'-mfpu=neon -mfloat-abi=softfp' for ARM Cortex-A8), then it gets into the
host tool compile, which then fails (because my build machine is not an
ARM Cortext-A8).  This can be fixed by using TARGET_CFLAGS and
TARGET_LDFLAGS, instead of CFLAGS and LDFLAGS, respectively.

Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/luajit/luajit.mk

index e4c46d8934f86e10b1387d31b77e5a13a2239600..913bc0c9e823283b8e5e89972646d35b278f3747 100644 (file)
@@ -42,8 +42,8 @@ define LUAJIT_BUILD_CMDS
                TARGET_LD="$(TARGET_CC)" \
                TARGET_AR="$(TARGET_AR) rcus" \
                TARGET_STRIP="$(TARGET_STRIP)" \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               LDFLAGS="$(TARGET_LDFLAGS)" \
+               TARGET_CFLAGS="$(TARGET_CFLAGS)" \
+               TARGET_LDFLAGS="$(TARGET_LDFLAGS)" \
                HOST_CC="$(LUAJIT_HOST_CC)" \
                HOST_CFLAGS="$(HOST_CFLAGS)" \
                HOST_LDFLAGS="$(HOST_LDFLAGS)" \