busybox: force ipv6 build
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sun, 19 Apr 2015 12:39:56 +0000 (09:39 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 22 Apr 2015 20:59:49 +0000 (22:59 +0200)
Since it isn't optional any more just force IPv6 on in busybox to avoid
problems.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/busybox/busybox.mk

index 95fdfec4e8e6a1a8a23f89257597db3187529744..1ce508a6b5b37f8d62e8ce4853a2d330800bb680 100644 (file)
@@ -97,18 +97,10 @@ define BUSYBOX_SET_LARGEFILE
        $(call KCONFIG_ENABLE_OPT,CONFIG_FDISK_SUPPORT_LARGE_DISKS,$(BUSYBOX_BUILD_CONFIG))
 endef
 
-# If IPv6 is enabled then enable basic ifupdown support for it
-ifeq ($(BR2_INET_IPV6),y)
 define BUSYBOX_SET_IPV6
        $(call KCONFIG_ENABLE_OPT,CONFIG_FEATURE_IPV6,$(BUSYBOX_BUILD_CONFIG))
        $(call KCONFIG_ENABLE_OPT,CONFIG_FEATURE_IFUPDOWN_IPV6,$(BUSYBOX_BUILD_CONFIG))
 endef
-else
-define BUSYBOX_SET_IPV6
-       $(call KCONFIG_DISABLE_OPT,CONFIG_FEATURE_IPV6,$(BUSYBOX_BUILD_CONFIG))
-       $(call KCONFIG_DISABLE_OPT,CONFIG_FEATURE_IFUPDOWN_IPV6,$(BUSYBOX_BUILD_CONFIG))
-endef
-endif
 
 # If we're using static libs do the same for busybox
 ifeq ($(BR2_STATIC_LIBS),y)