Use BR2_TOOLCHAIN_BUILDROOT instead of BR2_TOOLCHAIN_SOURCE
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 14 Dec 2009 11:10:12 +0000 (12:10 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 14 Dec 2009 22:54:47 +0000 (23:54 +0100)
The BR2_TOOLCHAIN_SOURCE option is removed in a future commit.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Makefile
package/Makefile.in
target/Config.in
toolchain/Config.in.1
toolchain/Config.in.2
toolchain/gcc/gcc-uclibc-3.x.mk
toolchain/uClibc/uclibc.mk

index 5b71051c12ef06748ea845460db254334020c9bb..051b661fe7fcbb47fd3c6b88ea7985d93608d777 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -197,7 +197,7 @@ PREFERRED_LIB_FLAGS:=--enable-static --enable-shared
 # along with the packages to build for the target.
 #
 ##############################################################
-ifeq ($(BR2_TOOLCHAIN_SOURCE),y)
+ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
 BASE_TARGETS:=uclibc-configured binutils cross_compiler uclibc-target-utils kernel-headers
 else
 BASE_TARGETS:=uclibc
@@ -289,7 +289,7 @@ include .config.cmd
 # We also need the various per-package makefiles, which also add
 # each selected package to TARGETS if that package was selected
 # in the .config file.
-ifeq ($(BR2_TOOLCHAIN_SOURCE),y)
+ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
 # avoid pulling in external toolchain which is broken for toplvl parallel builds
 # Explicit ordering:
 include toolchain/dependencies/dependencies.mk
index 7c009bbe00a74a910c1c902f4e8f98d6992ae375..25dd6da8153c7039b8519e40bf52a1c14c276ad8 100644 (file)
@@ -36,7 +36,7 @@ endif
 
 
 #########################################################################
-ifeq ($(BR2_TOOLCHAIN_SOURCE),y)
+ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
 TARGET_CFLAGS=$(TARGET_OPTIMIZATION) $(TARGET_DEBUGGING) \
        -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
 TARGET_LDFLAGS+=-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib
@@ -105,7 +105,7 @@ XXXX=xxxx
 ROOTFS_SUFFIX:=-$(BR2_ROOTFS_SUFFIX)
 endif
 
-ifeq ($(BR2_TOOLCHAIN_SOURCE),y)
+ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
 TOOLCHAIN_DIR=$(BASE_DIR)/toolchain
 
 # Quotes are needed for spaces et al in path components.
index ab46dcb162fcb972ebf7f3d488205ea30a44f38c..4cae66cf77614a39e9784d2e99bff36853c90c02 100644 (file)
@@ -74,7 +74,7 @@ config BR2_KERNEL_LINUX_ADVANCED
 # The kernel with the same version as linux headers cannot be compiled
 # when using an external toolchain, because the linux headers are not
 # handled by Buildroot in this case.
-if BR2_TOOLCHAIN_SOURCE
+if BR2_TOOLCHAIN_BUILDROOT
 
 config BR2_KERNEL_LINUX
        bool "linux (Same version as linux headers)"
index 83bc710b6d17ce2583fcdad4cf30d20e74f0ae36..5c26858d0ba240e5599d6e991c12947ca3da1ae4 100644 (file)
@@ -1,6 +1,6 @@
 #
 
-if BR2_TOOLCHAIN_SOURCE
+if BR2_TOOLCHAIN_BUILDROOT
 source "toolchain/kernel-headers/Config.in"
 source "toolchain/uClibc/Config.in"
 source "toolchain/binutils/Config.in"
index 2f7de75b66850b980f87659622ba52ebe3db7115..6317ff4fbdd40f6ab0cca259e717ca212218a8de 100644 (file)
@@ -37,7 +37,7 @@ config BR2_ENABLE_LOCALE
 
 config BR2_ENABLE_LOCALE_PREGENERATED
        bool "Use pregenerated locale data?"
-       depends on BR2_ENABLE_LOCALE && BR2_TOOLCHAIN_SOURCE && BROKEN # tarball missing
+       depends on BR2_ENABLE_LOCALE && BR2_TOOLCHAIN_BUILDROOT && BROKEN # tarball missing
        help
          Instead of generating the locale data locally you can optionally
          download a pregenerated set of locales.
@@ -142,7 +142,7 @@ config BR2_GCC_CROSS_CXX
 
 config BR2_INSTALL_LIBSTDCPP
        bool "Build/install c++ compiler and libstdc++?"
-       select BR2_LARGEFILE if (!BR2_GCC_SUPPORTS_SYSROOT && BR2_TOOLCHAIN_SOURCE)
+       select BR2_LARGEFILE if (!BR2_GCC_SUPPORTS_SYSROOT && BR2_TOOLCHAIN_BUILDROOT)
        select BR2_GCC_CROSS_CXX
        help
          If you are building your own toolchain and want to build and install
@@ -157,7 +157,7 @@ config BR2_TARGET_OPTIMIZATION
        help
          Optimizations to use when building for the target host.
 
-if BR2_TOOLCHAIN_SOURCE
+if BR2_TOOLCHAIN_BUILDROOT
 source "toolchain/elf2flt/Config.in"
 source "toolchain/mklibs/Config.in"
 source "toolchain/sstrip/Config.in"
index 0af3f38e65796fc02d4a06b9897c89f1d04f59a5..332af884a13339f8c8f5f4629f78d68fc4525eb2 100644 (file)
@@ -17,7 +17,7 @@
 # along with this program; if not, write to the Free Software
 # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
 
-ifeq ($(BR2_TOOLCHAIN_SOURCE),y)
+ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
 
 # without sysroot support. Sysroot toolchain is gcc-uclibc-4.x.mk
 ifneq ($(BR2_TOOLCHAIN_SYSROOT),y)
index 79d272fea615c5da3aa8894f5f37848d3507cf15..f742d4ef40283b9646572c78dce0931936e4316e 100644 (file)
@@ -4,7 +4,7 @@
 #
 #############################################################
 
-ifeq ($(BR2_TOOLCHAIN_SOURCE),y)
+ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
 
 # specifying UCLIBC_CONFIG_FILE on the command-line overrides the .config
 # setting.