gmp: dissable assembly for armv7m
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 20 Jun 2016 14:00:03 +0000 (11:00 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 3 Jul 2016 22:34:01 +0000 (00:34 +0200)
It has different assembly constraints which can't be satisfied. Fixes:
http://autobuild.buildroot.net/results/ac6/ac65384a325912788790ceafa7db657cef9382fa/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gmp/gmp.mk

index 45571900cd99f6338a3b8ef286ca6851c21b53cf..cdde7943951926b6e44b7c117e7119680c1f2f2e 100644 (file)
@@ -14,7 +14,8 @@ GMP_DEPENDENCIES = host-m4
 HOST_GMP_DEPENDENCIES = host-m4
 
 # GMP doesn't support assembly for coldfire or mips r6 ISA yet
-ifeq ($(BR2_m68k_cf)$(BR2_mips_32r6)$(BR2_mips_64r6),y)
+# Disable for ARM v7m since it has different asm constraints
+ifeq ($(BR2_m68k_cf)$(BR2_mips_32r6)$(BR2_mips_64r6)$(BR2_ARM_CPU_ARMV7M),y)
 GMP_CONF_OPTS += --disable-assembly
 endif