Makefile.autotools.in: fix make source-check/external-deps differently
authorPeter Korsgaard <jacmet@sunsite.dk>
Thu, 24 Jul 2008 13:38:39 +0000 (13:38 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 24 Jul 2008 13:38:39 +0000 (13:38 -0000)
The MAKELEVEL test is not that robust; It fails with the recent log
support or if buildroot is driven from an external Makefile.

Rework it to instead detect source-check/external-deps by the fact that
they set SPIDER.

Makefile
package/Makefile.autotools.in

index c23ec716055e0bc6723404ebefa6716d632b2785..8cadf5c3a344378ec33023833e3bc6d5239fd131 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -350,7 +350,7 @@ _source-check:
 
 external-deps:
        @$(MAKE) -Bs BR2_WGET=$(TOPDIR)/toolchain/wget-show-external-deps.sh \
-       source
+               SPIDER=--spider source
 
 #############################################################
 #
index 16fc371927aa6d8c95ee1025893ca6ad67ce36aa..5e94b447ed87aceb3a96b8aae630b2ed86f43cca 100644 (file)
@@ -131,7 +131,7 @@ TAR ?= tar
 # Retrieve and unpack the archive
 $(BUILD_DIR)/%/.stamp_downloaded:
 # support make source-check/external-deps
-ifeq ($(MAKELEVEL),1)
+ifneq ($(SPIDER),)
        $(WGET) -P $(DL_DIR) $($(PKG)_SITE)/$($(PKG)_SOURCE)
        $(if $($(PKG)_PATCH),$(WGET) -P $(DL_DIR) $($(PKG)_SITE)/$($(PKG)_PATCH))
 else