package/libfribidi: remove optional dependency to libglib
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 30 Oct 2016 17:29:18 +0000 (18:29 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 1 Nov 2016 15:18:59 +0000 (16:18 +0100)
Fixes vdr compile error:
http://autobuild.buildroot.net/results/725/7252decffe29e19051eed0554786651aee216573/

Instead of fixing fribidi.pc or adding optional CFLAGS to the vdr
package we remove the optional libglib dependency because it does not
contain "any thing substantial" as pointed out in an pull request sent
upstream: https://github.com/behdad/fribidi/pull/14

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libfribidi/libfribidi.mk

index 4e82a5e4df823b064d7321c74a3ce597f40f34a5..86e722a21187c43447c026eb3f45d1fff679267d 100644 (file)
@@ -14,11 +14,9 @@ LIBFRIBIDI_INSTALL_STAGING = YES
 # Run autoreconf to regenerate ltmain.sh.
 LIBFRIBIDI_AUTORECONF = YES
 LIBFRIBIDI_DEPENDENCIES = host-pkgconf
-
-ifeq ($(BR2_PACKAGE_LIBGLIB2),y)
-LIBFRIBIDI_DEPENDENCIES += libglib2
-else
-LIBFRIBIDI_CONF_OPTS += --with-glib=no
-endif
+# libglib2 dependency causes a build failure, and this optional
+# dependency is going to be removed usptream, see
+# https://github.com/behdad/fribidi/pull/14
+LIBFRIBIDI_CONF_OPTS = --with-glib=no
 
 $(eval $(autotools-package))