micropython: Add upstream patch to fix 64-bit builds
authorChris Packham <judge.packham@gmail.com>
Sun, 20 Sep 2015 08:44:35 +0000 (20:44 +1200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 20 Sep 2015 12:26:03 +0000 (14:26 +0200)
Fixes the following error when building for a 64-bit target

  ../py/objint_mpz.c:54:5: error: right shift count >= width of type [-Werror]
       (MP_SSIZE_MAX >> MPZ_DIG_SIZE * 4) & DIG_MASK,
       ^
  ../py/objint_mpz.c:54:5: error: initializer element is not constant
  ../py/objint_mpz.c:54:5: error: (near initialization for 'maxsize_dig[4]')

Signed-off-by: Chris Packham <judge.packham@gmail.com>
Reviewed-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Tested-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/micropython/micropython.mk

index 62668828af86fbb35d6584e905af9e4555264be0..f2ad5bf64e96621d6738e3e64de22221c3512b94 100644 (file)
@@ -9,6 +9,7 @@ MICROPYTHON_SITE = $(call github,micropython,micropython,$(MICROPYTHON_VERSION))
 MICROPYTHON_LICENSE = MIT
 MICROPYTHON_LICENSE_FILES = LICENSE
 MICROPYTHON_DEPENDENCIES = host-pkgconf libffi
+MICROPYTHON_PATCH = https://github.com/micropython/micropython/commit/8b4fb4fe140e9cf57fcfa258d0d2d6fe19090fc5.patch
 
 # Use fallback implementation for exception handling on architectures that don't
 # have explicit support.