mesa3d: Bump version to 10.2.1, fix xa build
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 7 Jun 2014 12:31:10 +0000 (14:31 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 8 Jun 2014 13:02:41 +0000 (15:02 +0200)
Building xa requires at least one non swrast gallium driver, needed since:
http://cgit.freedesktop.org/mesa/mesa/commit/configure.ac?h=10.2&id=e283e966660fdf037be6353dc96b7f63b8aa315a

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mesa3d/mesa3d.mk

index fa17177b0f8832add3966787fe0bc74188e2577f..1a61af8489f0185bd64ce4d208dfb961ec21fee2 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-MESA3D_VERSION = 10.0.4
+MESA3D_VERSION = 10.2.1
 MESA3D_SOURCE = MesaLib-$(MESA3D_VERSION).tar.bz2
 MESA3D_SITE = ftp://ftp.freedesktop.org/pub/mesa/$(MESA3D_VERSION)
 MESA3D_LICENSE = MIT, SGI, Khronos
@@ -35,9 +35,13 @@ MESA3D_DEPENDENCIES += \
        xlib_libXdamage \
        xlib_libXfixes \
        libxcb
-MESA3D_CONF_OPT += \
-       --enable-glx \
-       --enable-xa
+MESA3D_CONF_OPT += --enable-glx
+# quote from mesa3d configure "Building xa requires at least one non swrast gallium driver."
+ifneq ($(BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_NOUVEAU)$(BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_SVGA),)
+MESA3D_CONF_OPT += --enable-xa
+else
+MESA3D_CONF_OPT += --disable-xa
+endif
 else
 MESA3D_CONF_OPT += \
        --disable-glx \