package/libvips: add giflib optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Wed, 31 Mar 2021 18:59:43 +0000 (20:59 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 4 Apr 2021 11:58:27 +0000 (13:58 +0200)
giflib is an optional dependency which is enabled by default since
version 8.3.0 and
https://github.com/libvips/libvips/commit/d79407f285c768a7338e73ccfc6cf09480b95582

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libvips/libvips.mk

index 014aaf03279054ff1d5814b2c51b5b3ae6d58668..0449751380b74e20a2594125695a8a912ad2b6c4 100644 (file)
@@ -38,6 +38,13 @@ LIBVIPS_DEPENDENCIES = \
        host-pkgconf expat libglib2 \
        $(TARGET_NLS_DEPENDENCIES)
 
+ifeq ($(BR2_PACKAGE_GIFLIB),y)
+LIBVIPS_CONF_OPTS += --with-giflib
+LIBVIPS_DEPENDENCIES += giflib
+else
+LIBVIPS_CONF_OPTS += --without-giflib
+endif
+
 ifeq ($(BR2_PACKAGE_GOBJECT_INTROSPECTION),y)
 LIBVIPS_CONF_OPTS += --enable-introspection
 LIBVIPS_DEPENDENCIES += gobject-introspection