libvorbis: fix tremor install into staging_dir
authorPeter Korsgaard <jacmet@sunsite.dk>
Thu, 16 Jul 2009 13:07:20 +0000 (15:07 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 16 Jul 2009 19:47:36 +0000 (21:47 +0200)
Closes #387.

When tremor is selected, the normal libvorbis shouldn't get built and
tremer should get installed into staging_dir as well.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/multimedia/libvorbis/libvorbis.mk

diff --git a/CHANGES b/CHANGES
index 7278bdf601377aabe1479bb5d1d2623d8f9d6a3a..18beb146de162d034cb780284520f4d9ba34d9bd 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -12,6 +12,7 @@
        #379: update DirectFB to version 1.4.0
        #383: gst-plugins-good: Allow soup plugin to be configured
        #385: neon: Fix pkgconfig dependency
+       #387: Tremor not installed to toolchain
        #391: gstreamer: Bump version to 0.10.23
        #393: gst-plugins-base: Bump version to 0.10.23
        #395: gst-plugins-bad: New package
index e7399e038ad309f5dd055168b2b86a06aec2615e..6f904089d384c0548d4ed8029cc3d11dba9c70da 100644 (file)
@@ -4,6 +4,8 @@
 #
 #############################################################
 
+ifneq ($(BR2_PACKAGE_LIBVORBIS_TREMOR),y)
+
 LIBVORBIS_VERSION = 1.2.3
 LIBVORBIS_SOURCE = libvorbis-$(LIBVORBIS_VERSION).tar.gz
 LIBVORBIS_SITE = http://downloads.xiph.org/releases/vorbis/$(LIBVORBIS-SOURCE)
@@ -17,6 +19,7 @@ LIBVORBIS_DEPENDENCIES = uclibc host-pkgconfig libogg
 
 $(eval $(call AUTOTARGETS,package/multimedia,libvorbis))
 
+else
 
 ############################################################
 #
@@ -67,7 +70,11 @@ $(TREMOR_DIR)/.libs: $(TREMOR_DIR)/.configured
        $(MAKE) CC=$(TARGET_CC) -C $(TREMOR_DIR)
        touch $@
 
-$(TARGET_DIR)/usr/lib/tremor.so: $(TREMOR_DIR)/.libs
+$(STAGING_DIR)/usr/lib/tremor.so: $(TREMOR_DIR)/.libs
+       $(MAKE) prefix=$(STAGING_DIR)/usr -C $(TREMOR_DIR) install
+       touch $@
+
+$(TARGET_DIR)/usr/lib/tremor.so: $(STAGING_DIR)/usr/lib/tremor.so
        $(MAKE) prefix=$(TARGET_DIR)/usr -C $(TREMOR_DIR) \
                $(if $(BR2_STRIP_none),install,install-strip)
        touch $@
@@ -93,9 +100,6 @@ tremor-dirclean:
 # Toplevel Makefile options
 #
 ############################################################
-ifeq ($(BR2_PACKAGE_LIBVORBIS),y)
-ifeq ($(BR2_PACKAGE_LIBVORBIS_TREMOR),y)
 TARGETS+=tremor
-endif
-TARGETS+=libvorbis
+
 endif