package/civetweb: fix build without sync
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Tue, 4 Dec 2018 21:15:36 +0000 (22:15 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 6 Dec 2018 20:44:43 +0000 (21:44 +0100)
If BR2_TOOLCHAIN_HAS_SYNC_4 is not set, define -DNO_ATOMICS=1 to
fallback on lock

Fixes:
 - http://autobuild.buildroot.org/results/7b3bc71d64aedf617dde35798099e16d7ae46713

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[Thomas: invert condition.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/civetweb/civetweb.mk

index 4c3c443db74e0104f457da5d067bbddc0f028ce5..fe1cdd5675ac1d6887b7e80b9baa0b26ce088a7f 100644 (file)
@@ -21,6 +21,10 @@ CIVETWEB_INSTALL_OPTS = \
        HTMLDIR="$(TARGET_DIR)$(CIVETWEB_HTMLDIR)" \
        SYSCONFDIR="$(TARGET_DIR)$(CIVETWEB_SYSCONFDIR)"
 
+ifeq ($(BR2_TOOLCHAIN_HAS_SYNC_4),)
+CIVETWEB_COPT += -DNO_ATOMICS=1
+endif
+
 ifeq ($(BR2_PACKAGE_CIVETWEB_WITH_LUA),y)
 CIVETWEB_CONF_OPTS += WITH_LUA=1
 CIVETWEB_LIBS += -ldl